locked
Installed 2010 SDK, and niw XAML editor windows no longer show up RRS feed

  • Question

  • I can't pin it down for sure, but immediately after installing the 2010 SDK, I am no longer able to open XAML files in VS2010 - there is a brief 'flash' as something appears in the file editor area of the UI, and the XAML file is subsequently listed in the open Windows list.

    This problem is happening for any XAML file, be it Silverlight or WPF.

    I've tried a number of things, including uninstalling the SDK, and repairing .NET frameworks, and VS2010 itself. I even tried a system restore.

    Any ideas?

    Edit: I can also 'edit' the XAML by e.g. double-clicking on a control in the toolbox. This modifies the XAML document. It's just the window which is not shown. The changes made to the document can be saved.

    Edit II: A complete uninstall and reinstall of VS2010 didn't fix the problem.

    Edit III: After uninstalling many more bits and pieces, including VS2010 again, I tried logging in as a different user. VS worked fine for that user, which suggests it is a user-specific problem.

    • Edited by innes Thursday, September 30, 2010 5:13 PM
    Wednesday, September 29, 2010 3:50 PM

Answers

  • Using PROCMON to look at what registry entries VS2010 reads, I finally hit upon a solution to this problem:

    Delete this registry key:

    HKCU/software/microsoft/VisualStudio

     

    • Marked as answer by innes Thursday, September 30, 2010 5:14 PM
    Thursday, September 30, 2010 4:39 PM

All replies

  • Haven't seen that before. It sounds as if the editor was floated and moved to offscreen coords. Try resetting the IDE's window layout and see if that helps. Select the "Reset Window Layout" menu item, on the "Window" menu.

    Sincerely,

     

     


    Ed Dore
    Wednesday, September 29, 2010 7:37 PM
  • Thanks Ed, That sounded like it might be the answer, but sadly it didn't work.
    Thursday, September 30, 2010 9:47 AM
  • Using PROCMON to look at what registry entries VS2010 reads, I finally hit upon a solution to this problem:

    Delete this registry key:

    HKCU/software/microsoft/VisualStudio

     

    • Marked as answer by innes Thursday, September 30, 2010 5:14 PM
    Thursday, September 30, 2010 4:39 PM