none
Server 2003 Automating Application containing Word 2007 Reference RRS feed

  • Question

  • I have a VB6 application that reads emails, saves the text from the email to an html file.  Word opens the HTML file and saves to RTF.  All done within the app.  I have no problems with the code running on my local desktop under the scheduler.  The problems occur when I try to run this under the scheduler on a Windows 2003 server with Word 2007 installed.  It might run just fine the first time but may or not run again even if I manually kick it off.  If it does happen to run the 2nd time, I have strange behavior like it doesn't clean up the Word references or hangs.  If i create a shortcut to the app and run from the desktop, there are no problems.   I can run it this way as many times as I want to kick it off.  The problem is that I need this to run as an automation.  Can someone please help me with what the problem may be.  It appears to be directly tied to running as a service on Windows 2003 server.  I have exhausted my ideas and have been trying to get this resolved for months.  Help please!  Thanks in advance.
    Tuesday, May 17, 2011 7:40 PM

Answers

  • I have a VB6 application that reads emails, saves the text from the email to an html file. Word opens the HTML file and saves to RTF. All done within the app. I have no problems with the code running on my local desktop under the scheduler. The problems occur when I try to run this under the scheduler on a Windows 2003 server with Word 2007 installed. It might run just fine the first time but may or not run again even if I manually kick it off. If it does happen to run the 2nd time, I have strange behavior like it doesn't clean up the Word references or hangs. If i create a shortcut to the app and run from the desktop, there are no problems. I can run it this way as many times as I want to kick it off. The problem is that I need this to run as an automation. Can someone please help me with what the problem may be. It appears to be directly tied to running as a service on Windows 2003 server. I have exhausted my ideas and have been trying to get this resolved for months. Help please! Thanks in advance.

     

     

    It look like that you want to automatic Office in service-side. You might want to read the KB article first:

    Considerations for server-side Automation of Office

     

    I hope this helps.


    Best Regards, Calvin Gao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, May 25, 2011 6:26 AM
    Moderator
  • Thank you Calvin.
    • Marked as answer by NetLost Friday, May 27, 2011 3:55 PM
    Friday, May 27, 2011 3:55 PM

All replies

  • I have a VB6 application that reads emails, saves the text from the email to an html file. Word opens the HTML file and saves to RTF. All done within the app. I have no problems with the code running on my local desktop under the scheduler. The problems occur when I try to run this under the scheduler on a Windows 2003 server with Word 2007 installed. It might run just fine the first time but may or not run again even if I manually kick it off. If it does happen to run the 2nd time, I have strange behavior like it doesn't clean up the Word references or hangs. If i create a shortcut to the app and run from the desktop, there are no problems. I can run it this way as many times as I want to kick it off. The problem is that I need this to run as an automation. Can someone please help me with what the problem may be. It appears to be directly tied to running as a service on Windows 2003 server. I have exhausted my ideas and have been trying to get this resolved for months. Help please! Thanks in advance.

     

     

    It look like that you want to automatic Office in service-side. You might want to read the KB article first:

    Considerations for server-side Automation of Office

     

    I hope this helps.


    Best Regards, Calvin Gao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, May 25, 2011 6:26 AM
    Moderator
  • Thank you Calvin.
    • Marked as answer by NetLost Friday, May 27, 2011 3:55 PM
    Friday, May 27, 2011 3:55 PM