none
Windows 7 RTM Cursor Bug

    Question

  • Hello. I recently installed windows 7 rtm professional, which I got from the MSDN Academic Alliance program and there seems to be a very annoying bug in the cursor. Whenever I open a new window my cursor seems to be offset from where I click the mouse. This happens in all of my new windows. For example when I try to click the close button on opened windows I am cannot because the cursor is offset such that it's location is above where the click location is. I have tried installing the synaptic drivers for the mouse pad but that didn't do anything to alleviate the problem. The only thing I can do to work around this problem is to minimize the window, click on the desktop, and then maximize the window again - but this has gotten old very fast. What should I do to fix the problem?

    System:
    Acer Extensa 4420
    Windows 7 RTM Professional
    • Moved by Max Wang_1983 Tuesday, April 26, 2011 1:26 AM forum consolidation (From:Windows Error Reporting for ISVs)
    Monday, August 31, 2009 2:42 PM

All replies

  • I know that this question was posted a while ago, but I had the same problem and wanted to quickly share how I solved it.

    -Open control panels and then Mouse Properties
    -Choose the Pointer Options tab
    -Uncheck the box for Enhance Pointer Precision
    -Press OK or Apply

    Your cursor should now be placed where you click, not where Win 7 thinks the cursor should have been placed...

    Kind of ironic that a feature called "Enhance Pointer Precision" would degrade rather than enhance precision, but there you have it.  Hope this helps someone out.
    • Proposed as answer by cryptological Wednesday, December 30, 2009 7:44 PM
    Tuesday, December 29, 2009 8:53 PM
  • I know that this question was posted a while ago, but I had the same problem and wanted to quickly share how I solved it.

    -Open control panels and then Mouse Properties
    -Choose the Pointer Options tab
    -Uncheck the box for Enhance Pointer Precision
    -Press OK or Apply

    Your cursor should now be placed where you click, not where Win 7 thinks the cursor should have been placed...

    Kind of ironic that a feature called "Enhance Pointer Precision" would degrade rather than enhance precision, but there you have it.  Hope this helps someone out.

    Have you bought the released version of Win 7? Is the problem still exist in the released version?
    Saturday, June 19, 2010 10:27 AM
  • Yes the release version has the same problem. It's most annoying and the group which signed off should be taken to task. You type a credit card number and it's all over the place.
    mysorian
    Friday, July 16, 2010 8:31 PM
  • Hi,  I HAD this problem, followed the simple advice of CRYPTOLOGICAL and, he presto, problem resolved!!!!  Fantastic and so simple.  Equally, in Word my cursor was always a tad to the left of where I thought I was putting it - this problem also fixed!  Thanks Cryp.
    Saturday, July 17, 2010 1:56 PM
  • I've been struggling with having to click on the first (or sometimes second or later) pixel of the next character to the right of where I want the cursor, ever since I bought this new machine with Win7. 

    At first I thought this "uncheck precision" tip had solved my problem, but now that I've re-checked it to make sure the problem came back...  it didn't! 

    It looks like my problem is program and font size dependent. In Word (2007) using Bookman 8pt, the flashing insertion point is two pixels wide. If there is only one white pixel between characters, the left half of the insertion point goes there, and the right half covers the beginning of the next letter. But when I'm clicking to place the insertion point, I must click where the right half will go, or my insertion point will show up a whole character to the left. 

    In Excel (2007) with Calibri 9pt, the insertion point is only one pixel wide, but I still must click where the pixel to the right of the insertion point will go, to avoid it jumping a whole character to the left. 

    Trying this here, using Google Chrome at 100%...  All of these require clicking on the first pixel of the 'h', 's', or 'n'; if I click on the whitespace the cursor goes before the 't', 'i', or <space>: 

    th

    is

    t n

    In this one I must click the second pixel of the 't' (its main vertical stroke) or the cursor goes ahead of the <space>:

    , t

    As in Excel, the single-pixel-wide insertion point appears one pixel to the left of where I clicked in those cases. Usually if you just arrow key the insertion point along a line, it will stop in the white pixels between characters. But for the 't', it actually stops on the first pixel of the character - but then there isn't any blank pixel included on either side of those 't' characters in this font: 

    tttttttt

    (It will be interesting to visit this post in other browsers, and see what happens. Except it looks like the display font here is different from the composition font...)

    I guess we're down to the question of why Microsoft insists on putting the insertion point ahead of a character if you click anywhere within that character, or in any white space attached to the right side of it in the current font. I don't know what modern Macintosh systems do, but back on the Mac+ where I learned about this wimp interface, if you clicked past the midpoint of a character the insertion point appeared after the character. It made editing so much easier! 

    I don't remember WinXP having this problem quite so obviously, but my old XP systems had different screen resolutions and different versions of programs defaulting to different fonts, so maybe XP and 7 share the same insertion point behavior. 

    If anyone knows how to change where the insertion point appears relative to your click, please tell! Can you edit the "hotspot" of the cursor, so your clicks appear a pixel to the right of where you see the cursor? Or would you have to edit every character of every font? Is this possibly due to different design philosophies in TrueType fonts versus PostScript fonts? 

    Loren

     

     

    Monday, August 23, 2010 12:41 AM
  • As I suspected, the display font behaves differently. You need to mouse down and drag to see where your insertion point landed. The first three pairs (th, is, t n) behave properly (by Windows conventions) in the display font. For the ", t" test, I still need to click on the first pixel of the 't' to get just the 't', but I don't have to go clear over to the main vertical stroke like in the composition font. 

    Loren

     

    Monday, August 23, 2010 12:47 AM
  • I am not sure if this problem is present exclusively on laptops/notebooks/netbooks where you use the touch sensitive pads to make mouse moves. The thing that fixed this annoyance was to disable the touch pad and use an external mouse. This has mostly eliminated this problem.

    mysorian
    Friday, August 27, 2010 1:18 PM
  • It is still there. Terrible!

    Also the search.


    mysorian
    Tuesday, April 26, 2011 2:45 AM
  • I have the same exasperating issue on my Asus A8N-SLI and Maximus Extreme towers, as well as my Dell E1505 laptop.  It's not the platform; it's the OS.  I can't believe the user community isn't screaming their brains out about this.

    - John

    Friday, June 10, 2011 4:15 AM
  • I can't believe the user community isn't screaming their brains out about this.
    John, I totally agree with you. I can confirm the apprent "fix" of unchecking the enhanced precision does NOT work. I have seen the same proplem occur on EVERY W7 laptop I have used, not just my own. The ONLY workarond I have found to work is by ( as I have done now ), moving the cursor to a part of the screen where it is not possible to type, in this instance, outside this typing area. Microsoft, get a grip this has been going on for YEARS, so FIX THE ISSUE!! ...or is it a feature?
    Wednesday, August 31, 2011 7:46 AM
  • hi y'all

    I have Windows7 Professional in 2011 and in every appication the cursor is all over the shop like a mad woman's shit,which is really bad when trying to enter passwords when the characters are represented as dots for some reason. Also makes it fun writing SQl statements and binary strings.

     

    I got cryptological's fix and will be trying it out. Thanks for that. But seriously, disabling pointer precision makes the pointer more realistic? And having it enabled is by default and after over a year of fixes it is still throwing the cursor everywhere?

     

    If I were more cynical I might suggest that this is seriously unprofessional. Considering it is a new feature not available in previous versions that worked fine.

     

    If the fix works, I will be passing it on and ridiculing the OS that requires disabling a default feature in order to make things work.

     

    Thanks for the assist cryptological. Kudos

     

     

     

    Saturday, November 12, 2011 9:35 AM
  • Helloo Jayraman: Internal/ or external no matter the prob exists. Wonder why people still use the WINDOWS OS. Windows and Microsoft should have retired right after Billy Goates. It is tension creating and unhealthy.....eh? And now look at the 'Apology' at the top of screeen in a yellow box ! ! ! That makes my point stronger. Never have any such probs. in the Macintosh - Apple computer system.Nor does it need bulky [bigger than the budget of the US} UPDATES {every 1/2 day}. And no problem of viruses of any sort any where. Billy Goates on the other hand seem to be invaded / or attracted by the virus germs all the time. Why? With his huge huge MS-UNIVERSITY of computer vizs he could easily invent a simple, fast [like DOS} OS like the unix/ or Linux.no..no...He is bent on showing the 'hello world' a creation that is so heavy that it can hardly walk. Forget about a 'swift run'. He has been busy 101% of time in adding to the OS and making it heavier and heavier every chance he could get. As a matter of that the WINDOWS' pc's have to BE constantly upgraded in its hardware to cope with the demands of this good-for-nothing ADD-ONS IN THE OS. I do not see any point in wasting our-ALL'S time in pursuing a problem that should not have existed right at the first sight.Windows has probs.arising every day and minute.So why fight and create a FORUM just for trifle subjects like 'cursors'.Let us free ourselves of WINDOWS OS/ and pc's. So my advice [not asked/ uninvited]is to switch to some other OS than the infamous Windows. Linux is simple, rich and does more than than heavy-load windows applications [word, Power point, spread sheet program...you name it and the heaviest load is present] Thank U Jayaram. My apology for intruding into your help to the members.I took over the driver's seat. But is about time we wake up and see what is running to our expectations, is fast, is simple and does not need a huge parahernelia. The time of economical designs and lean/mean budget have come. Gone are the yester days/years of 15 cents/ a gallon gas price. The world supplies are slowly dwindling and we have to be cautious in keeping ample We now pay only $3.50/gallon of gasoline. AND WE ARE LOOKING FOR A $2 or less per gallon of world economy. Billy Goates philosophy does not seem to help in this direction and we must not use it or we will simply slow ourselves down and be world's last number country. Which we proudly seem to posess right now in almost all walks of life.And now 'you know THE REST OF THE STORY'..... My sincere Namaskar/greetings to ya ALL.
    Wednesday, December 07, 2011 10:54 AM
  • And problem still exists in Win7 SP1, 6.1.7601.

    Chris

    Monday, September 10, 2012 6:11 PM
  • 2009 to 2012 is a long stretch in the scope of software products. Microsoft has gone from Windows 7 to Windows 8 but they seem not to care to fix this problem. I recently installed Windows 7 Ultimate x64 bit on my laptop. I use a Microsoft mouse and this problem still persists.x this problem

    Why do they still keep the Windows 7 team? time to fire them.


    mysorian

    "2009 to 2012 is a long stretch in the scope of software products. Microsoft has gone from Windows 7 to Windows 8 but they seem not to care to fi x this problem. I recently installed Windows 7 Ultimate x64 bit on my laptop. I use a Microsoft mouse and this problem still persists.x this problem"

    This piece of text was due to the cursor jump about which I am ranting:

    x this problem


    • Edited by Jayaram Krishnaswamy Friday, January 11, 2013 9:07 PM opened up 'fix' to show the jump point
    Friday, January 11, 2013 9:02 PM