locked
A local Workspace is required Error RRS feed

  • Question

  • My issue is the along the same lines of this post which has no solution http://social.msdn.microsoft.com/Forums/en-US/tfsgeneral/thread/e3ca9af1-ebc0-4d8e-b4da-fbf028583402/.

    My specific problem is my VS 2005 team explorer has stopped working when dealing with workspaces.  I get this error every time I open VS 2005 and any time when I try to update my workspaces:

    A local workspace is required.  Workspace <computer name>;<user name> does not reside on this computer.

    I also get another error when opening projects in VS 2005 and trying to add them to source control stating:

    Object reference not set to an instance of an object.

    When I try to use the option Change Source Control I get the same error as above with no option to Connect to TFS. 

    These errors started to occur when I had to change my computer name.   I was successfully able to update my computer name in the TfsVersionControl database table tbl_Workspace.  I run both VS 2005 and VS 2008 on my box and VS 2008 has no problems with workspaces.  My question is whether or not it is possible to update my VS 2005 TFS client to acknowledge that I do indeed have a local workspace?  I have tried running tf workspaces /s:<server name> and reinstalling the TFS Client with no success.

    Wednesday, July 8, 2009 3:26 PM

Answers

All replies

  • Hi Travis,

    To clear the client cache of team explorer, you can wait for about two hours TE will automatically refresh the cache or you can clear it manually:

    1. Close Visual Studio
    2. Delete contents under folder: %UserProfile%\Local Settings\Application Data\Microsoft\Team Foundation\1.0\Cache\
    3. Start Visual Studio
    4. Re-add TFS server


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    • Proposed as answer by Pete Wilkins Thursday, February 17, 2011 2:35 PM
    Thursday, July 9, 2009 6:13 AM
    Moderator
  • I think running
    tf workspaces /updateComputerName /s:xxxx
    http://msdn.microsoft.com/en-us/library/54dkh0y3(VS.80).aspx
    may help (and this is how computer name should be updated in tfs)
    Good luck!
    Michal Malecki
    Monday, July 13, 2009 1:13 PM
  • Hi Travis,

    Is this issue resolved?
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Tuesday, July 14, 2009 6:06 AM
    Moderator
  • This did the trick for me.  Thank you Hongye!

    I had changed my computer name, and then ran the tf workspaces /updatecomputername command from the VS 2010 command prompt.  All was well until I opened VS 2008 to work with an older solution file.  I received the infamous error:

    "A local workspace is required.  Workspace <computer name>;<user name> does not reside on this computer."

    I opened the VS 2008 command prompt and ran the the tf workspaces /s command and sure enough, the computer name listed for all my workspaces was incorrect.  I attempted to run the tf workspaces /updatecomputername command and received the same error that I got from within the VS 2008 IDE.

    I followed Hongye's steps and everything is working again in VS 2008.  Note: the version listed in the path corresponds to the version of TFS.

    • 1.0 = 2005
    • 2.0 = 2008
    • 3.0 = 2010
    Thursday, February 17, 2011 2:31 PM
  • Michal,

    That is not quite the correct command line syntax. When you use the /updateComputerName option, you must also specify a TFS server. The correct command line syntax is therefore,

     

    tf workspaces /s:<tfs_server_name> /updateComputerName:<old_computer_name>

    Those are the instructions given on the page whose url you posted. When I tried it, it worked for me.

    Thanks!

    Russell de Pina

    Tuesday, December 20, 2011 5:10 PM
  • it works for me
    Tuesday, October 6, 2015 1:16 PM