locked
Can't get Console connect to work in Azure Pack RRS feed

  • Question

  • Hi guys,

    I've configured a Azure Pack environment and rolled-out my first virtual machine in it. 
    I'm limited in the use of machines so this is my setup:

    DomainController,
    Webserver (with Azure Pack on it)
    2 Hyper-V machines (1 with Remote Desktop Gateway installed on it)
    1 MSSQL server
    1 VMM server

    I've configured the certificates needed for getting console connect to work but still I'm unable to get this to work. When i connect to the virtual machine using console connect i see the following messages appear in the event viewer:

    * RDP ClientActiveX is trying to connect to the server (hypv002.*******.com)
    * The multi-transport connection has been disconneted.
    * RDP ClientActiveX has been disconnected (Reason= 2308)

    And the following message appears on the screen immediately after pressing "connect" in the RDP screen:

    "Can't connect to the remote computer"

    All machines have the certificate I've made using MakeCert (self-signed) in there trusted root store. 

    I really don't know what I'm missing or doing wrong here.....


    Wednesday, April 9, 2014 7:36 AM

Answers

  • Well... 

    I'm soooooo stupid... 

    I was trying to connect to the console while working on a Server 2012 R2 Machine.. and this made me thinking of my situation. 

    I Deployed an Windows 7 X64 machine with all the latest updates installed on it and guess what?!


    It works!!!

    • Marked as answer by Bart Pasmans Tuesday, April 15, 2014 11:11 AM
    Tuesday, April 15, 2014 11:11 AM

All replies

  • Hi,

    It seems like this issue was more related with Microsoft Azure Pack, I will move this thread to Microsoft Azure Pack Forum for a better help.
    Thank you for your understanding.

    Best Regards


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 10, 2014 1:23 AM
  • Please see our whitepaper - covering Hybrid Cloud with NVGRE, which also contains information around setup of Remote Console for Windows Azure Pack, and explains the pitfalls you may run into.

    http://gallery.technet.microsoft.com/Hybrid-Cloud-with-NVGRE-aa6e1e9a

    Let me know if this helps you.

    In general, i would suspect that the Hyper-V Management Server Service requires a restart on every hosts (so that the certificate is registered, if using self-signed certs), or that you need to configure your VMM add-on on the gateway over again.

    -kn


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )

    Thursday, April 10, 2014 10:16 AM
  • Well... 

    I'm soooooo stupid... 

    I was trying to connect to the console while working on a Server 2012 R2 Machine.. and this made me thinking of my situation. 

    I Deployed an Windows 7 X64 machine with all the latest updates installed on it and guess what?!


    It works!!!

    • Marked as answer by Bart Pasmans Tuesday, April 15, 2014 11:11 AM
    Tuesday, April 15, 2014 11:11 AM