none
Visual Studio 2015 Update 1 claims I'm debugging a Release build

    Question

  • After updating to VS 2015 update 1, if I run a web project (MVC), stop the application, then try to run again, VS stops and pops up a dialog claiming "you are debugging a Release build of . Using Just My Code with release builds using compiler optimizations results in degraded debugging experience (e.g. breakpoints won't be hit)"

    The problem is.. I'm NOT running a RELEASE build. I'm clearly running the (same) debug build I just ran!

    Why does VS think I'm running a release build?

    Cleaning the solution and re-running clears the error message, so something is hosed somewhere.

    • Moved by Kristin Xie Wednesday, December 2, 2015 4:21 AM move to better forum
    Tuesday, December 1, 2015 7:35 PM

Answers

  • Hi TsomJ,

    I create a new MVC web project after install Update 1 and it works with Debug mode correctly (Just My Code is on).

    Please create a new project to make sure whether this problem occurs with this specific project or with all project.

    If just with this specific project, there may cache something by Visual Studio. So after you cleaning the solution and re-running clears the error message. Besides, please remove the .suo file which saves user settings for current solution.

    If with all project, please try with following steps to troubleshoot this problem.

    1.Reset all settings through menu Tools -> Import and Export settings -> Reset all settings.
    2.Clear all caches under following paths:
       C:\Users\v-weiwca\AppData\Local\Temp
       C:\Users\username\AppData\Local\Microsoft\WebsiteCache
       C:\Users\username\AppData\Local\Microsoft\VisualStudio\12.0\ComponentModelCache
       C:\Users\username\AppData\Local\Microsoft\VisualStudio\12.0\ManifestCache
    3.Repair you Visual Studio 2015.

    Best Regards,
    Weiwei

    Thursday, December 3, 2015 1:32 AM
    Moderator

All replies

  • Go to Solution, Right click and select Properties. Select Configuration Properties - Configuration and check each project configuration and change to Debug if it shows Release.

    Also, right click on the Project and select Properties, click on Build tab and make sure Optimize Code option is un-checked. also click on Define Debug Constant.

    Reference:

    http://stackoverflow.com/questions/31992705/vs2015-project-no-longer-runs-in-debug-mode


    Thanks, AT

    Tuesday, December 1, 2015 7:54 PM
  • Yes, as I said I am running in a DEBUG configuration, and the Optimize checkbox is OFF.

    Again.. The first time I run the project, it do not get the message, everything works fine.

    Stopping the project, then running it again, the message shows. The project doesn't even rebuild, the message pops up right away.

    The only way to remove the message is to turn off the "Just My Code" setting in the Debugger options... but I believe that is a workaround / hack at best. "Just My Code" was always on, with no problems before "Update 1".

    Wednesday, December 2, 2015 11:21 AM
  • Hi TsomJ,

    I create a new MVC web project after install Update 1 and it works with Debug mode correctly (Just My Code is on).

    Please create a new project to make sure whether this problem occurs with this specific project or with all project.

    If just with this specific project, there may cache something by Visual Studio. So after you cleaning the solution and re-running clears the error message. Besides, please remove the .suo file which saves user settings for current solution.

    If with all project, please try with following steps to troubleshoot this problem.

    1.Reset all settings through menu Tools -> Import and Export settings -> Reset all settings.
    2.Clear all caches under following paths:
       C:\Users\v-weiwca\AppData\Local\Temp
       C:\Users\username\AppData\Local\Microsoft\WebsiteCache
       C:\Users\username\AppData\Local\Microsoft\VisualStudio\12.0\ComponentModelCache
       C:\Users\username\AppData\Local\Microsoft\VisualStudio\12.0\ManifestCache
    3.Repair you Visual Studio 2015.

    Best Regards,
    Weiwei

    Thursday, December 3, 2015 1:32 AM
    Moderator