none
MapPolyline distortion RRS feed

  • Question

  • I have noticed that MapPolyline on a Windows Store seems to distort depending on the dimensions of the Map Control.

    Here is a MapPolyline rendered when the Map Control is 1500x800:

    Here is a MapPolyline rendered when the Map Control is 1500x400:

    The coordinates for each polyline are the same, however in the second image, the width of the segments of the polyline seem to change when they are more 'vertically diagonal'. The difference may at first seem subtle, but IMO, it very much impacts the user experience, making it harder to see, and definitely less elegant.

    Is there a workaround for this?

    Thanks
    -Wayne

    Tuesday, September 9, 2014 8:25 PM

Answers

  • Wow, that's a very odd issue that I haven't noticed before. I'm able to reproduce this when using snap mode. I'll log this as a bug with our dev team. However, I don't expect this to be something that would be a simple fix. Strangle enough this doesn't occur with the route line in the built-in Map app. It also appears this only occurs when the map is resized. If you load the data again when the map is a different size it renders correctly. So, although this isn't ideal, a workaround would be to remove and read the data after the map has resized.

    http://rbrundritt.wordpress.com


    Wednesday, September 10, 2014 9:16 AM
  • There is no public visible list to track bugs. If you have an enterprise license for Bing Maps you can report the issue to the support team and they can provide you with a bug ID which you can us in the future to request a status up from them. Talking with our team this looks to be a fairly minor issue and likely won't be fixed in the current version of the map control, but will likely be corrected in the next version.

    http://rbrundritt.wordpress.com

    Thursday, September 18, 2014 11:22 AM

All replies

  • Wow, that's a very odd issue that I haven't noticed before. I'm able to reproduce this when using snap mode. I'll log this as a bug with our dev team. However, I don't expect this to be something that would be a simple fix. Strangle enough this doesn't occur with the route line in the built-in Map app. It also appears this only occurs when the map is resized. If you load the data again when the map is a different size it renders correctly. So, although this isn't ideal, a workaround would be to remove and read the data after the map has resized.

    http://rbrundritt.wordpress.com


    Wednesday, September 10, 2014 9:16 AM
  • Thanks for the reply. I'm glad you can replicate the issue.

    I also see the issue even if the map is not resized (although that's a good way to replicate it). If I have the map dimensions explicitly set as a wide rectangle but not the full resolution (in my case 1500x300 on a 1600x900 monitor), I also see the problem.

    And of course, the problem is exacerbated if the line width of the Polyline is thick, e.g. 15 pixels.

    Am I able to track this issue so I can see what the progress on a possible fix would be?

    Wednesday, September 10, 2014 10:34 AM
  • There is no public visible list to track bugs. If you have an enterprise license for Bing Maps you can report the issue to the support team and they can provide you with a bug ID which you can us in the future to request a status up from them. Talking with our team this looks to be a fairly minor issue and likely won't be fixed in the current version of the map control, but will likely be corrected in the next version.

    http://rbrundritt.wordpress.com

    Thursday, September 18, 2014 11:22 AM