none
Daylight saving time with enhanced write filter WES7 64bit RRS feed

  • Question

  • Hi there!

    We have a problem with the daylight saving time, when the enhanced write filter is enabled.

    But this problem only occures with WES-7 64bit. With WES-7 32bit everything is working fine.

    What we do:

    - WES-7 64 bit with all current updates

    - EWF is disabled

    - set time Zone to W. Europe Standard Time

    - Create registry key RealTimeIsUniversal under HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation as DWORD and set it to 1

    - Restart the system, open the BIOS and set BIOS time to current UTC Time

    - Restart the system and enable EWF

    When we now go back to the BIOS and set the time to April 1st 2018 and restart the System everything is working fine.

    Then we set the BIOS time to November 1st 2018 and start Windows again, we see a EWF- help window, which says:

    "This application can be used to display and configure settings of the enhanced write filter"

    We can click OK and the window disappears. But after a reboot, the window is back again.

    And some icons in the task bar are not visible.

    We are struggling with this error for over a year and still have no solution.

    It doesn't matter what we do (with or without updates, different date, etc.), we can reproduce this error when we cross the time border two times.

    And, as I wrote, this ONLY happens on WES-7 64bit.

    Thank you in advance

    Friday, February 2, 2018 6:29 AM

All replies

  • This forum is for POSReady. I will move it to the WES7 forum.

    Sounds like there is a mix of problems here.

    1. Even though you have followed the UTC recommendation: https://msdn.microsoft.com/en-us/library/jj980285%28v=winembedded.81%29.aspx?f=255&MSPPError=-2147217396, the time is not getting set correctly when daylight savings occurs? Is that correct?

    2. The EWF utility pop up sounds like the Enhanced Write Filter Provider or Management Tool components are in the image. I though there was a fix for these KB2539566


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Friday, February 2, 2018 4:15 PM
    Moderator
  • Hello Sean,

    Yes, I followed the UTC recommendation.

    The package KB2536566 is installed but the Problem stays.

    When I open "msconfig" and disable the ewfmgmt.exe under startup, the EWF Utility pop-up does not come up, when I run through the DST- border twice. By some Icons in the taskbar, like Network and notifications, are not visible.

    Monday, February 12, 2018 2:44 PM
  • The popup-issue sounds familiar to me. AFAIR it applied to WES2009/Xpe, but may apply here too. In my case there was something wrong with the UserInit setting in the registry - see here for details.

    Usually there is only "C:\WINDOWS\system32\userinit.exe," - if not, revert it to this value and check if this fixes your problem.

    Tuesday, February 13, 2018 9:05 AM
  • Thank you, but this was not the Problem. 

    The value is "C:\Windows\system32\userinit.exe," as you wrote.

    But I found this article. And this is my Problem.

    But here is no suggestion how  to solve this problem.

    Do any of you guys know how to solve this?

    Tuesday, February 13, 2018 11:57 AM
  • Can you verify that deleting the icon cache as described here helps to get rid off your troubles?

    Regardigng the pop-up of the EWF utility - this may also occour when ewfmgmt.exe launches while another instance is already running (e.g. Startup-item in Startmenu AND registry)

    Tuesday, February 13, 2018 12:30 PM
  • Yes, I tried this suggestion, but without success.

    I think we will write a piece of code to solve this problem fast.

    Thank you for help guys!  

    Thursday, February 15, 2018 2:33 PM