none
This add-in is no longer available: add-ins inserted during development RRS feed

  • Question

  • Hi,

    I have made an Excel AddIn. I have deployed it on the Web Server. I have a trusted catalog on development machine. I have copied the manifest (with changed <SourceLocation DefaultValue>) into the catalog folder. Everything work when I open an Excel file and make Insert->My Add-ins->SHARED FOLDERS->MyAddIn. Than I am saving the file. Exit, start new and open the file again and this error comes:

    ADD-IN ERROR

       This add-in is no longer available: add-ins inserted during development are only available during debugging from Visual Studio. Please ...........

    Why I get this error and how can I repair it?

    Best Regards


    Mottor

    Friday, April 29, 2016 12:17 PM

Answers

  • Hi all,

    I have found what to do.  Go on File->Info->Inspect Workbook  Check for Issues -> Inspect Document -> Inspect.

    Than on "Task Pane Add-ins" click Remove All.  

    Thank you 


    Mottor

    • Marked as answer by Mottor Monday, May 2, 2016 2:23 PM
    Monday, May 2, 2016 2:23 PM

All replies

  • Hi Mottor,

    is visual studio running when you call the addin first time?

    what about the second time?

    did you perform all the steps correctly? can you verify it again?

    please visit the links below.

    Create a network shared folder catalog

    Regards

    Deepak


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 2, 2016 9:44 AM
    Moderator
  • Hi Deepak,

    >is visual studio running when you call the addin first time?

    No.

    If I make a new Excel file and make Insert Add-In and then save it. The next time, when I open the file is everything OK. 

    In the file which I use (7 sheets with tables and charts) I am deleting the add-in and save the file, then exit and start again. Now, when I make Insert add-in, everything is OK, but when I save and start again I get the error. I am using  shared folder catalog and have tested it on 3 computers. The same. It is something in the excel file, remained from the time of the development with Visual Studio, but I do not know what is it and how to clear it.

    Best Regards


    Mottor


    • Edited by Mottor Monday, May 2, 2016 2:15 PM
    Monday, May 2, 2016 1:38 PM
  • Hi all,

    I have found what to do.  Go on File->Info->Inspect Workbook  Check for Issues -> Inspect Document -> Inspect.

    Than on "Task Pane Add-ins" click Remove All.  

    Thank you 


    Mottor

    • Marked as answer by Mottor Monday, May 2, 2016 2:23 PM
    Monday, May 2, 2016 2:23 PM
  • Hi Mottor,

    Its nice to hear from you that you have got the solution of your issue by yourself.

    Also you have share the solution with our community so that it can help other community member.

    Thank you for sharing Solution.

    Regards

    Deepak


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 3, 2016 3:21 AM
    Moderator
  • I am getting same issue. I have deployed my site on azure and share manifeast file from network path. when i download document from task pane(office js) and open newly downloaded document, it is giving me error.

    I don't want to go every time to inspect document and save it. open again. Please do needful.

    • Edited by Keyur.Patel Monday, December 26, 2016 10:04 AM
    Monday, December 26, 2016 10:01 AM
  • Hi Keyur.Patel,

    This thread is already closed.

    it is possible that you are getting the error because of some other issue.

    so for better response and better solution I suggest you to create a new thread and describe your issue with detail.

    so that community members can understand it properly and try to give you suggestion to solve your issue.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 27, 2016 1:25 AM
    Moderator
  • Even if this is already closed:

    VERY helpful, that issue was a real pane and it is not only a problem when you add an add-in for debug.

    The same is true when you change the server that is hosting the manifest, which in my eyes is not only a problem but also a security issue (see link)

    https://social.technet.microsoft.com/Forums/office/en-US/b0e027d9-ca29-4d2b-9007-01d59dd2ca2e/this-addin-is-no-longer-available-from-the-following-server-?forum=Office2016ITPro



    • Edited by PLindlau Friday, March 3, 2017 9:14 AM
    Friday, March 3, 2017 9:13 AM
  • Hi PLindlau,

    when you change the server that is hosting the manifest, I suggest you to redeploy your addin from the scratch.

    it can solve your issue.

    when you change the server then in may not be able to find that addin. so it returns an error.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 6, 2017 1:08 AM
    Moderator
  • Thanks, but it does find the add-in.

    Please have a look at the given link - there I explain in detail  how to reproduce the problem.

    https://social.technet.microsoft.com/Forums/office/en-US/b0e027d9-ca29-4d2b-9007-01d59dd2ca2e/this-addin-is-no-longer-available-from-the-following-server-?forum=Office2016ITPro

    In short:

    When I detach the add-in from the Workbook, save the workbook, open it again, then Insert the Addin from the new server, this will work!

    However, now saving it, closing the file and re-opening it will still look for the "old" server to fetch the manifest (even though I have inserted it from the new server!!!) - to me this is just a bug.

    That's a real pain, given a larger corporation where you want to deploy ONE Excel-Template which should be hosted from various locations, dependend on where a given user is located.

    The idea cannot be to re-create the template for every different location...

    This matter kills the idea of creating Excel templates with Add-Ins.

    Cheers - Peter

    Monday, March 6, 2017 12:16 PM
  • I forgott to mention:

    Excel 2013 does NOT have that problem - there it works as expected!

    This behavior is new to Excel 2016!

    Monday, March 6, 2017 12:59 PM
  • Hi PLindlau,

    please try to submit your feedback to user voice regarding this issue.

    Excel developers will try to test this issue on their side.

    if they found the problem then they can try to correct it in next update.

    Excel user voice

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 7, 2017 5:58 AM
    Moderator
  • Good Morning,

    it already sits there since Nov. 2016:

    https://officespdev.uservoice.com/forums/224641-feature-requests-and-feedback/suggestions/17002894-trusted-catalog-shared-folder-incompatibility-e

    It is very frustrating that no one seems to be interested in this issue.

    It makes me believe that this API does not really have attention at Microsoft.

    Wednesday, March 8, 2017 7:20 AM
  • Hi PLindlau,

    we can only submit our feedback.

    when they will correct the issue , you will be notified.

    till then we have to wait.

    they have lots of issues to check, correct it, review it, develop new features.

    so it take some time.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 8, 2017 8:40 AM
    Moderator