none
Adding an entity model causes "Visual Studio is busy" message RRS feed

  • Question

  • So I'm doing this-

    1. New Project (take your pick, repros with any project type, console, asp.net, mvc3...)

    2. Right click project, Add New Item... - > Data -> ADO.NET Entity Data Model

    3. In the Entity Data Model Wizard, I chose Empty model -> Finish

    Visual Studio freezes with a message in the system tray "Visual Studio is busy. If you see this message often contact Microsoft support". Something along those lines.

    I've tried a complete uninstall of VS and reinstall. Still the same. Haven't seen any issues anywhere else in Visual Studio. 

    Does anyone know of any reason that could cause this? I can't repro this at home or on another computer at work. Repros 100% on my dev machine. 

    Has anybody seen something like this before? 

    Thanks in advance!


    Saturday, February 18, 2012 2:39 AM

Answers

  • Hi Aniket,

    Welcome!

    Firstly, you can try to run the steps in Safe Mode of your system to see if it works.

    Then, I think you can try the following command: devenv /resetsettings (http://msdn.microsoft.com/en-us/library/xee0c8y7.aspx)

    Have a nice day.


    Alan Chen[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 20, 2012 7:35 AM
    Moderator
  • Thanks Alan, for the reply.

    Sorry, but resetting settings didn't work either.

    I did manage to find the culprit. 

    I had a VS-Ultimate DVD in the DVD drive. For whatever reason, every time I performed an operation related to EF, the DVD drive was being accessed. 

    That being slow, it would take forever to perform the simplest of EF related tasks. I took the disk out and the problem no longer repros. 

    I agree it seems very strange that this would happen, but fact is, it works fine right now. :-)


    Thursday, February 23, 2012 6:56 PM

All replies

  • Hi Aniket,

    Welcome!

    Firstly, you can try to run the steps in Safe Mode of your system to see if it works.

    Then, I think you can try the following command: devenv /resetsettings (http://msdn.microsoft.com/en-us/library/xee0c8y7.aspx)

    Have a nice day.


    Alan Chen[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 20, 2012 7:35 AM
    Moderator
  • Hi,

    I am writing to check the status of the issue on your side. Would you mind letting us know the result of the suggestions?
    If you need further assistance, please feel free to let me know. I will be more than happy to be of assistance.

    Have a nice day.


    Alan Chen[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, February 23, 2012 2:06 AM
    Moderator
  • Thanks Alan, for the reply.

    Sorry, but resetting settings didn't work either.

    I did manage to find the culprit. 

    I had a VS-Ultimate DVD in the DVD drive. For whatever reason, every time I performed an operation related to EF, the DVD drive was being accessed. 

    That being slow, it would take forever to perform the simplest of EF related tasks. I took the disk out and the problem no longer repros. 

    I agree it seems very strange that this would happen, but fact is, it works fine right now. :-)


    Thursday, February 23, 2012 6:56 PM