none
Have someone else enter a password for a connection manager RRS feed

  • Question

  • Hi,

    I have a connection manager pointing to an Oracle database using the Attunity connector. I can set the password as an expression and use a project parameter there. So far so good... If I set the project parameter to be sensitive it converts to dots. Obviously I can set sensitive to false again and read the password.

    The requirement I have is to create the package, create the parameter and have a system administrator add the password. Next I should be able to use that password in my connection while creating, debugging and deploying my packages. But I should not be able to read it.

    What is the best way to do this? Is it as simple as setting the SSIS package protection level to EncryptSensitiveWithPassword? (I don't want to use EncryptSensitiveWithUserKey as the system admin can perhaps leave the company)

    Tuesday, August 8, 2017 5:09 AM

Answers

  • Hi Rudi,

    If the issue has been resolved, would please mark an appropriate reply as answer or share your solution to close the thread?

    Thanks,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Rudi Hendrix Wednesday, August 16, 2017 12:22 PM
    Tuesday, August 15, 2017 7:58 AM
    Moderator

All replies

  • Hi Rudi Hendrix,

    I think you could try to parameterize your password with project parameter. Please refer to following steps:

    1. Parameterize password.

    2. Deploy the package to SSISDB.

    3. Configure the package located in SSIS catalog.

    Check if this meets your requirement.

    You could also check this article: Using sensitive parameters (SSIS Series)

    Regards,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, August 9, 2017 9:49 AM
    Moderator
  • Hi Rudi,

    If the issue has been resolved, would please mark an appropriate reply as answer or share your solution to close the thread?

    Thanks,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Rudi Hendrix Wednesday, August 16, 2017 12:22 PM
    Tuesday, August 15, 2017 7:58 AM
    Moderator
  • Hi Rudi,

    If the issue has been resolved, would please mark an appropriate reply as answer or share your solution to close the thread?

    Thanks,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Hi Pirlo,

    For some reason I wasn't able to respond before this.

    The option that you provide seems like a good one. Wouldn't I be able to set the parameter to not sensitive and read the password then?

    Right now I have created a separate environment in the SSIS Catalog. That's where I have had the administrator enter the password for the connection. Seems to be working and as soon as I try to read it the password is blanked out.

    Thanks for your help. As we're currently setting up stuff I may try that one as well.

    Regards,
    Rudi

    Tuesday, August 15, 2017 9:00 PM