none
Error when trying to upload an image RRS feed

  • Question

  • Hi!

    I'm trying to upload an image to my container name "vhds" inside storage account "pruebasatfacr" but I'm getting the following error:

    [root@vmlbcatfl49 KVM]# azure storage blob upload -a pruebasatfacr -k "$base64string"  --container vhds

    info:    Executing command storage blob upload

    File name: azure-POSTGRES-9.3.2-RHEL-65.X64.ATF.PRB-disk1.vdh

    + Checking blob azure-POSTGRES-9.3.2-RHEL-65.X64.ATF.PRB-disk1.vdh in container vhds

    error:   getaddrinfo ENOTFOUND

    info:    Error information has been recorded to azure.err

    error:   storage blob upload command failed

    [root@vmlbcatfl49 KVM]# cat azure.err

    Fri Jan 02 2015 09:07:47 GMT+0100 (CET):

    { [Error: getaddrinfo ENOTFOUND]

      stack: [Getter/Setter],

      code: 'ENOTFOUND',

      errno: 'ENOTFOUND',

      syscall: 'getaddrinfo',

      __frame:

       { name: '__1',

         line: 270,

         file: '/usr/lib/node_modules/azure-cli/lib/util/storage.util._js',

         prev:

          { name: 'StorageUtil_performStorageOperation__1',

            line: 251,

            file: '/usr/lib/node_modules/azure-cli/lib/util/storage.util._js',

            prev: [Object],

            active: false,

            offset: 19,

            col: 4 },

         active: false,

         offset: 2,

         col: 15 },

      rawStack: [Getter] }

    Error: getaddrinfo ENOTFOUND

        at errnoException (dns.js:37:11)

        at Object.onanswer [as oncomplete] (dns.js:124:16)

        at __1 (/usr/lib/node_modules/azure-cli/lib/util/storage.util._js:272:15)

        at StorageUtil_performStorageOperation__1 (/usr/lib/node_modules/azure-cli/l

        at uploadAzureBlob (/usr/lib/node_modules/azure-cli/lib/commands/asm/storage

    I guess that can be a DNS issue but I need more information about that, does anyone know why can it be caused?

    Thanks in advance!

    Friday, January 2, 2015 8:28 AM

Answers

  • Hi, Enrique,

    Please verify if your storage account endpoint can be resolved by dns.  try nslookup <your account name>.blob.core.windows.net . Also, you can try some other commands such as list containers, list blobs and see if they work or not.

    Regards, Chungang

    Saturday, February 28, 2015 6:44 AM

All replies

  • Hi,

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue.

    Regards,

    Mekh.

    Saturday, January 3, 2015 6:55 AM
    Moderator
  • Hi Enrique,

    Please confirm how exactly you are trying to upload the file(Blob) to your Azure Storage container.

    You may use AzCopy or AzureStorageExplorer to upload any file(Blob) to your Container.

    You may also refer:

    http://azure.microsoft.com/en-us/documentation/articles/storage-dotnet-how-to-use-blobs/#upload-blob

    Regards,

    Manu Rekhar

    Sunday, January 4, 2015 10:55 AM
    Moderator
  • Looks like you have 2 '-' in the container parameter?

    [root@vmlbcatfl49 KVM]# azure storage blob upload -a pruebasatfacr -k "$base64string"  --container vhds


    Frank

    Sunday, January 4, 2015 1:06 PM
  • Hi again and thanks for your response!

    I have a VM with Azure CLI tool running with RHEL 6.5, so that I think i can't use AzCopy only compatible for Windows O.S.

    The file that I want to upload is located on Azure CLI server and I execute de following command:

    [root@vmlbcatfl49 KVM]# azure storage blob upload -a pruebasatfacr -k "$base64string"  --container vhds

    info:    Executing command storage blob upload

    File name: azure-POSTGRES-9.3.2-RHEL-65.X64.ATF.PRB-disk1.vdh

    + Checking blob azure-POSTGRES-9.3.2-RHEL-65.X64.ATF.PRB-disk1.vdh in container vhds

    error:   getaddrinfo ENOTFOUND

    info:    Error information has been recorded to azure.err

    error:   storage blob upload command failed

    Further info related to this error:

    [root@vmlbcatfl49 KVM]# cat azure.err

    Fri Jan 02 2015 09:07:47 GMT+0100 (CET):

    { [Error: getaddrinfo ENOTFOUND]

      stack: [Getter/Setter],

      code: 'ENOTFOUND',

      errno: 'ENOTFOUND',

      syscall: 'getaddrinfo',

      __frame:

       { name: '__1',

         line: 270,

         file: '/usr/lib/node_modules/azure-cli/lib/util/storage.util._js',

         prev:

          { name: 'StorageUtil_performStorageOperation__1',

            line: 251,

            file: '/usr/lib/node_modules/azure-cli/lib/util/storage.util._js',

            prev: [Object],

            active: false,

            offset: 19,

            col: 4 },

         active: false,

         offset: 2,

         col: 15 },

      rawStack: [Getter] }

    Error: getaddrinfo ENOTFOUND

        at errnoException (dns.js:37:11)

        at Object.onanswer [as oncomplete] (dns.js:124:16)

        at __1 (/usr/lib/node_modules/azure-cli/lib/util/storage.util._js:272:15)

        at StorageUtil_performStorageOperation__1 (/usr/lib/node_modules/azure-cli/l

        at uploadAzureBlob (/usr/lib/node_modules/azure-cli/lib/commands/asm/storage

    Is it possible to continue exploring this option with the CLI tool to upload  the file (.vhd)?

    Monday, January 5, 2015 8:28 AM
  • Please updating the Azure-Cli to 0.8.13 and check once

    https://github.com/Azure/azure-xplat-cli/releases

    Regards,

    Manu Rekhar

    Monday, January 5, 2015 10:41 AM
    Moderator
  • AzureCli is already updated to 0.8.13:

    [root@vmlbcatfl49 ~]# azure -v
    0.8.13

    but i get same error:

    ...

    info:    Executing command storage blob upload
    File name: azure-POSTGRES-9.3.2-RHEL-65.X64.ATF.PRB-disk1.vdh
    + Checking blob azure-POSTGRES-9.3.2-RHEL-65.X64.ATF.PRB-disk1.vdh in container vhds
    error:   getaddrinfo ENOTFOUND
    info:    Error information has been recorded to azure.err
    error:   storage blob upload command failed

    Friday, January 9, 2015 8:24 AM
  • Hi, Enrique,

    Please verify if your storage account endpoint can be resolved by dns.  try nslookup <your account name>.blob.core.windows.net . Also, you can try some other commands such as list containers, list blobs and see if they work or not.

    Regards, Chungang

    Saturday, February 28, 2015 6:44 AM