Blend shows "Invalid Markup" for every page with errors like: "Page is not supported in a Windows App Project" RRS feed

  • Question

  • All of a sudden my windows 8 app (XAML, C#) can't be edited in Blend for Visual Studio.  Every .xaml  page is marked with "Invalid Markup" on pretty much every tag used in the file.  At first I thought it was related to Visual Studio 2012 Update 2, so I uninstalled everything and installed just Update 1 but after compiling once the same error happened again.  Some of the references in the project have that yellow exclamation mark in Blend even though the references work fine in VS 2012.  I tried removing them and reading them in Blend but that didn't work.  I even started up a brand new project in Blend and added the same references and it worked and I compared the .csproj files and everything is pretty much the same.  I am using the multilingual toolkit, is it possible  Blend doesn't play nice with it?  I know it was working recently though so I am skeptical that is the issue.  Is there anyway to help narrow down what is making Blend choke?
    Wednesday, April 17, 2013 3:42 PM


All replies

  • Moving to the tools forum.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Wednesday, April 17, 2013 4:49 PM
  • Hi,

    I'll try to involve more experts in this case.

    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, April 19, 2013 9:33 AM
  • I would appreciate that.  I will provide any information that will help.
    Friday, April 19, 2013 2:06 PM
  • Would be happy to take a look, but will need a little more info. Could you please get in touch with me offline at unnir at Microsoft dot com?


    Unni Ravindranathan, Program Manager, Visual Studio and Blend This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, April 23, 2013 5:18 AM
  • As Unni propopsed, installing the latest Update 3 RC did the trick for me:



    Tuesday, June 11, 2013 8:34 AM
  • Yep, that worked for me too.  I wish Unni had proposed that for me as well ;).  Thanks.
    Wednesday, June 12, 2013 5:17 AM