none
Can't Install .Net Framework 2.0 redirect on XP SP3 To Run The Best Spinner RRS feed

  • Question

  • Basically that's the question.  How do I go about getting 2.0 to install?  I have 1.1, 3.0, 3.5 and get the error message that it can't be installed because it's not compatible with a more recent version.  In order to run my program The Best Spinner, I have to have this installed. 

    What can I do?

    Wednesday, March 24, 2010 8:56 PM

Answers

  • If you have your PC installed .NET Framework 3.0 and 3.5, then your system must already have .NET 2.0 installed.

    Becuase .NET Framework 3.0 and 3.5 will be installed on top of .NET 2.0 in a PC.  When you install these Frameworks (3.0/3.5), they will install .NET 2.0 and related service packs first and then install .NET 3.0/3.5 on top of it.

    You may need to uninstall previous version of your application(Best Spinner) first if they already installed in the PC.

    Friday, March 26, 2010 4:56 AM
  • Hello,

    You may also utilize Verification Tool to verify whether .Net Framework is installed well on your machine, if not, you may uninstall them and try to install the .NET Framework 3.5 SP1 because it will install the .NET Framework 2.0 SP2 and 3.0 SP2 behind the scenes, and these versions contain additional fixes not in the original 2.0, 3.0 or 3.5 releases.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Friday, March 26, 2010 10:20 AM
    Moderator

All replies

  • If you have your PC installed .NET Framework 3.0 and 3.5, then your system must already have .NET 2.0 installed.

    Becuase .NET Framework 3.0 and 3.5 will be installed on top of .NET 2.0 in a PC.  When you install these Frameworks (3.0/3.5), they will install .NET 2.0 and related service packs first and then install .NET 3.0/3.5 on top of it.

    You may need to uninstall previous version of your application(Best Spinner) first if they already installed in the PC.

    Friday, March 26, 2010 4:56 AM
  • Hello,

    You may also utilize Verification Tool to verify whether .Net Framework is installed well on your machine, if not, you may uninstall them and try to install the .NET Framework 3.5 SP1 because it will install the .NET Framework 2.0 SP2 and 3.0 SP2 behind the scenes, and these versions contain additional fixes not in the original 2.0, 3.0 or 3.5 releases.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Friday, March 26, 2010 10:20 AM
    Moderator