locked
why IIS 10.0 can not be install url rewrite 2.0 in win 10 preview RRS feed

  • Question

  • User645277476 posted

    why IIS 10.0 can not be install url rewrite 2.0 in win 10 preview

    I try sigle download url rewrite 2.0 to install, will be stop install to show IIS need 7.0 upper.

    and try install in webPI but same show it.

    Wednesday, April 1, 2015 8:11 PM

Answers

  • User1010943358 posted

    Fixed the problem.

    1. Open Regedit > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetStp
    2. Edit "MajorVersion" and set the "DECIMAL" value to 9
    3. Hit F5 while in Regedit
    4. Now go install the ReWrite 2.0 module.
    5. Change the "MajorVersion" back to "DECIMAL" value of 10
    6. Hit F5 while in Regedit
    7. Close Regedit

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, April 17, 2015 2:27 PM

All replies

  • User1183424175 posted

    Hi,

    According to your description, your OS is chinese. I've tested it with English OS which works for me. I've no chinese lab.

    But you can provide the web PI log which can help us track the issue.

    Thursday, April 2, 2015 4:17 AM
  • User645277476 posted

    thank you, you can check. i upload English version now.

    how i can show web PI log to you,

    I upload to web url is: http://www.txsbdb.com/rewriteurl2LOG.txt

    I hope you can see it. log file is too much long so can not to be change JPG

    Friday, April 10, 2015 9:34 PM
  • User645277476 posted

    I think the problem is rewrite url 2.0 test IIS version is : 7.0 = 70  (only 2 ddigit)

    than test IIS version >=70 so the new IIS 10.0  just version =10.

    so 10 > 70  rewrete url 2.0 can not pass test

    and than IIS 10.0 can not install rewreit url 2.0

    Friday, April 10, 2015 9:43 PM
  • User-1318856761 posted

    I'm also seeing this issue on an English build of 10049. Is there a value we can edit somewhere to fix this version check? Or perhaps force the installation to continue?

    Monday, April 13, 2015 5:46 PM
  • User1010943358 posted

    I have the same problem. IIS 10.0 installed and can't install rewrite 2.0 module.

    That is a very bad version checker that only uses "1" character to the right and left of the decimal...

    Friday, April 17, 2015 2:18 PM
  • User1010943358 posted

    Fixed the problem.

    1. Open Regedit > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetStp
    2. Edit "MajorVersion" and set the "DECIMAL" value to 9
    3. Hit F5 while in Regedit
    4. Now go install the ReWrite 2.0 module.
    5. Change the "MajorVersion" back to "DECIMAL" value of 10
    6. Hit F5 while in Regedit
    7. Close Regedit

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, April 17, 2015 2:27 PM
  • User645277476 posted
    Thank , this is will. I had install.
    Thursday, April 23, 2015 9:31 AM