locked
<?xml version="1.0" encoding="utf-8"?> (Horst Klein) - 1/30/2007 2:31 AM PST RRS feed

  • Question

  • By: Horst Klein

    One basic question
    
    Is there a reason why in the xaml files
    the "XAML Header" <?xml version="1.0" encoding="utf-8"?> is not defined?
    Is this a default value?
    
    Horst
    
    Tuesday, February 19, 2008 7:57 PM

Answers

  • By: Adrian Vinca [MSFT]

    Hello Horst,

    Indeed, utf-8 is the default value. As I know, the only reason why the
    encoding statement isn't defined is to generate less xaml. Are you hitting
    any issues because of that?

    Thanks,
    - Adrian Vinca [MSFT]
    Content is provided "AS IS" with no warranties and confers no rights.
    Opinions are my own and do not represent those of my employer.

    "Horst Klein" <HorstKlein@discussions.microsoft.com> wrote in message
    news:54F6C06F-0D6D-4E2D-923E-0DF0668E29D2@microsoft.com...
    > One basic question
    >
    > Is there a reason why in the xaml files
    > the "XAML Header" <?xml version="1.0" encoding="utf-8"?> is not defined?
    > Is this a default value?
    >
    > Horst
    >

    Tuesday, February 19, 2008 10:50 PM

All replies

  • By: Adrian Vinca [MSFT]

    Hello Horst,

    Indeed, utf-8 is the default value. As I know, the only reason why the
    encoding statement isn't defined is to generate less xaml. Are you hitting
    any issues because of that?

    Thanks,
    - Adrian Vinca [MSFT]
    Content is provided "AS IS" with no warranties and confers no rights.
    Opinions are my own and do not represent those of my employer.

    "Horst Klein" <HorstKlein@discussions.microsoft.com> wrote in message
    news:54F6C06F-0D6D-4E2D-923E-0DF0668E29D2@microsoft.com...
    > One basic question
    >
    > Is there a reason why in the xaml files
    > the "XAML Header" <?xml version="1.0" encoding="utf-8"?> is not defined?
    > Is this a default value?
    >
    > Horst
    >

    Tuesday, February 19, 2008 10:50 PM
  • By: Horst Klein

    Hi Adrian
    
    Thanks for your swift feedback.
    You confirm my speculation.
    I don't have any problem with that ;-)
    
    We build a Function to manipulte the xaml before we save it in the Database.
    So if its handled as default, we don't add it :-)
    
    Best regards
    Horst
    Tuesday, February 19, 2008 10:52 PM