none
Problem after installing new version of JDE OneWorld (JDEOW) Adapter RRS feed

  • Question

  • We just upgraded the JDEOW (JDEdwards OneWorld) adapter to a newer version, and suddenly my JDE ports are failing with the message below. 

     

    For some reason, the ports are trying to use the old version of the adapter DLLs (1.0.1069.0) instead of the new version (1.0.5012.0).  I've confirmed that the GAC has the new DLLs. 

     

    I've tried the following without success:

    • Removing BizTalk App and all GAC'ed assemblies, Recompiling, and Redeploying Application.
    • creating  a new JDEOW send port. 
    • removing and recreating the JDEOW send handler
    • replacing the "old" JDEAccess.jar with the newer one

    Can anyone tell me how to make the ports recognize the new DLL version?

     

    Thanks!

    Kelly Meade
    JR Simplot Co
    BizTalk 2006 R2

     

    The Messaging Engine failed to create the transport adapter "JDEOW".

    OutboundAssemblyPath: "NULL"

    OutboundTypeName: "Microsoft.BizTalk.Adapters.JDEOneWorldTransmitter, Microsoft.BizTalk.Adapters.CoreTransmitter, Version=1.0.1069.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    Exception Details: "Could not load file or assembly 'Microsoft.BizTalk.Adapters.CoreTransmitter, Version=1.0.1069.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified."

    Friday, October 24, 2008 3:11 PM

Answers

  •  

    Hi Kararra,

     

    I hope you performed following steps before installing new set of JDEOW Adapter.

    1. Stop all BizTalk Application in BizTalk Admin console.
    2. Stop HOST INSTANCE.
    3. Remove old Handler for JDEOW.
    4. Uninstall Old  BizTalk Adapters from Add/Remove programs.
    5. Check there should not be any old files in GAC, C:\Program Files\Common Files\Microsoft BizTalk Adapters for Enterprise Applications and C:\Program Files\Microsoft BizTalk Adapters for Enterprise Applications

    Install new set of BizTalk Adapter and check all places mentioned in step 5 for new files and Dlls i.e. ver 5012. Make sure you restarted the HOST INSTANCE after installing new adapters.

     

    Regards,

    Sanjay

     

     

    Tuesday, November 11, 2008 4:46 AM

All replies

  • Nobody has any thoughts on how to fix this issue???

     

    Monday, November 10, 2008 5:55 PM
  •  

    Hi Kararra,

     

    I hope you performed following steps before installing new set of JDEOW Adapter.

    1. Stop all BizTalk Application in BizTalk Admin console.
    2. Stop HOST INSTANCE.
    3. Remove old Handler for JDEOW.
    4. Uninstall Old  BizTalk Adapters from Add/Remove programs.
    5. Check there should not be any old files in GAC, C:\Program Files\Common Files\Microsoft BizTalk Adapters for Enterprise Applications and C:\Program Files\Microsoft BizTalk Adapters for Enterprise Applications

    Install new set of BizTalk Adapter and check all places mentioned in step 5 for new files and Dlls i.e. ver 5012. Make sure you restarted the HOST INSTANCE after installing new adapters.

     

    Regards,

    Sanjay

     

     

    Tuesday, November 11, 2008 4:46 AM
  •  

    Thanks Sanjay.  I appreciate your response.  I think we did all these steps, but we'll try again to be sure.

     

    Thanks!

    Tuesday, November 11, 2008 2:52 PM