locked
text blurring in Visual Studio 2010 RRS feed

  • General discussion

  • Hello,

      I have just installed VS2010. My "visual experience" is that the main text is verry blurry. I'm wondering, because on the other side the text in the SolutionExplorer is clear.

    What can I do to get clear text in the source code editor???

    Best regards
    Roy
    • Moved by Charles SterlingMicrosoft employee Tuesday, May 26, 2009 6:56 PM Moving the Editor Forum for Brittany, Sean and the gang to look at it too (From:Microsoft Visual Studio Team Foundation Server 2010 Beta 1)
    • Moved by Brittany Behrens Monday, June 14, 2010 10:52 PM (From:Visual Studio Editor)
    Monday, May 25, 2009 2:06 PM

All replies

  • Hi Roy,

    We've seen some issues with the way that WPF fonts are rendered in the past, and I'd like to learn more about this.

    Do you have a screenshot of the blurry text that you're seeing?  Also, any details about the video card and monitor you're using would be helpful (as the font rendering can be different on different devices).

    Thanks,
    Matthew Mitrik | Program Manager | TFS | Version Control | Migration | Twitter
    Tuesday, May 26, 2009 6:35 PM
  • here is a snapshoot.



    not clearly as vs2008.

    on my two machines vs2010b1 performs the same display and performance.

    1.not clearly enough :-(
    2.really slow.But only beta1, hope improvement in the future

    With following machine:
    1.Windows7 7106 x86/P4D 2.8GHz/3GB ram
    2.Windows7 7127 x64/Core2 E8300/4Gb ram
    Wednesday, May 27, 2009 1:51 AM
  • Hello,

      there is a picture to illustrate the problem

    VS2008 SourcecodeEditor / VS2010 SolutionExplorer-> clear, brilliant.
    VS2010 SourcecodeEditor -> the font appears more bold and with a blur effect

     

    Monitor is 24inch with 96dpi, 1920x1200Pixel, Nvidia Quadro FX3500

    ... I see now, MS will make a significant improvement in Beta2.

    Roy

    Thursday, May 28, 2009 12:39 PM
  • Hi Roy,

    Unfortunately, the blurry text is a known issue in Beta 1.  The WPF team has been working quite hard to improve text rendering and we're expecting a dramatic improvement in this area in Beta 2.  You can get the full details at the end of this discussion thread: http://social.msdn.microsoft.com/forums/en-US/wpf/thread/5289ee56-6d06-4f66-84f2-69865b6dc401/.

    In the meantime, you can improve your experience by ensuring that you are using a font designed for ClearType (such as Consolas the default) and running the ClearType tuner tool: http://www.microsoft.com/typography/cleartype/tuner/Step1.aspx. This tool is integrated in Windows Vista and Windows 7 RC. 

    Thanks!
    -Sean Laberee
    Program Manager - VS Platform Team

    Saturday, May 30, 2009 7:28 AM
  • The default environment font is Consolas. Try Tahoma or Courier New, with Bold or Regular, which suits you.
    Monday, June 1, 2009 8:45 PM
  • Also, some elements like popup menus use gray smoothing instead of color ClearType. I know this may seem a good idea (disable ClearType for surfaces that may become transparent) but it's not good for the eyes. When you open a popup menu made with WPF, it's like when you set up ClearType with the wrong stripping (i.e. BGR instead of RGB), you see it blurry for a while.
    Btw the gray ClearType renders quite bad on some screens (especially on laptop screens where color changes a lot with the viewing angle, you can't find a good angle to have correct smoothing).
    I think you should either allow fully disabling font smoothing (would be more consistent as font smoothing is not doable in some situations - quite a lot in fact if you like transparency), either modify something to use gray font smoothing the least you can.
    For example IIRC the main IDE About Box uses gray font smoothing instead of color. Is there any reason for that?
    I'm a student, and a hobbyist programmer (freeware pc apps & video game consoles), using VS 2008.
    • Edited by Brunni Monday, June 1, 2009 9:24 PM
    Monday, June 1, 2009 9:19 PM
  • Same issue here. Try using Lucida Console. I think it's better for source, at least on my settings.
    Wednesday, June 10, 2009 1:35 PM
  • I have the same issue. I've changed the font name and size but it didn't work. the issue available in visual web developer  2010 express too.

     

    Sunday, June 13, 2010 6:03 AM
  • I had a similar problem where the main text was blurry, but other text was fine. I found the scroll bar arrows were also blurry. 

    Then I remembered I had turned on 8x AA for all applications in the NVIDIA control panel. I changed the setting back to "application controlled" and restarted.

    All fixed!

    Not sure if its your problem, but it may work for you. 

    Friday, July 16, 2010 3:34 AM
  • I had this probem too, I changed everything in the NVIDIA control panel to application controlled and it worked like a charm.

    Thanks !


    it's all very nice when it works
    Monday, July 26, 2010 12:13 PM