none
The debugger was unable to terminate one or more processes

    Question

  • Visual Studio 2015 Error

    Press the Start debugging on a blank Cordova JavaScript app, Android, Ripple - Nexus S, then press the stop debugging. Visual Studio throws the following error message:

    The debugger was unable to terminate one or more processes:
    http://localhost:4400/index.html?enableripple=cordova-3.0.0-NexusGalaxy: The debugger is still attaching to the process or the process is not currently executing the type of code selected for debugging

    The debugger may be unstable now. It is recommended that you save all files and exit.

    Saturday, March 12, 2016 5:26 AM

All replies

  • Hi GUS,

    Not debug your app, if you just run it using "Start without debugging(Ctrl+F5)", how about the result?

    >>The debugger was unable to terminate one or more processes:
    http://localhost:4400/index.html?enableripple=cordova-3.0.0-NexusGalaxy: The debugger is still attaching to the process or the process is not currently executing the type of code selected for debugging

    Based on the error messages, it seems that it is related to the debug types you select in the attach to process window. Maybe you could check/change the debug code type in your side.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, March 14, 2016 3:33 AM
    Moderator
  • Hello, sorry to luck.

    if I run it without debugging (Ctrl+F5) it works perfect.

    Next I went under the Debug Menu, Attach to Process (ctrl +alt +p), changed the radio button option to Debug these code types, and unselected everything, then tried again, same error message.

    I'm able to reproduce the exact same error message on 2 different machines (Windows 7) and also (Windows 10) after a fresh first time install of Visual Studio Enterprise 2015, version 14.0.24720.00 Update 1.

    Thursday, March 24, 2016 3:41 AM
  • Hi GUS,

    Please run your VS as the admin.

    Please also use certain tool like the process monitor to check that whether this process was locked by other tools/process.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, March 29, 2016 3:22 AM
    Moderator
  • I am getting this issue as well.  Was there a resolution.  Ive tried all the above

    JohnB

    Sunday, October 30, 2016 9:10 PM