none
How do I configure Outlook? RRS feed

  • Question

  • I'm trying to send e-mails by automating Outlook from Visual FoxPro. I create the Outlook object and Namespace and e-mail message with appropriate body and recipient (so far, only to myself), and then send it (loNewMsg.Send() ), but the message always winds up in my Outbox instead. This happens, in fact, even when I compose a new message in Outlook and send it to myself. It never reaches me in my usual e-mail provider (AT&T webmail) - nor in my Outlook Inbox, for that matter. Where does it wind up? In my Outlook Outbox folder.

    Thanks for your help!


    Peyton

    Wednesday, August 14, 2013 5:27 PM

Answers

  • Hi Petun.

    Could you send email successfully through Outlook manually?

    If not, I’d like you to check you Outlook setting and make sure you can send email through Outlook. I’ll also recommend you to post your question to Outlook IT Pro Discussions forum if you have any issue on using Outlook.

    If you can not connect to AT&T webmail, I would like you to check the settings in outlook from the below steps:

    1 Open Microsoft Outlook. Outlook 2010 users need to click on "File" on the top menu bar. Choose "Info" and then "Account Settings." Choose "Account Settings" again. Outlook 2007 users need to click "Tools" on the top menu bar. Select "Account Settings" from the list.

    2 Select the "Email" tab.  Click the "New" button. Click the radio button next to "Microsoft Exchange, POP3, IMAP, or HTTP." Click "Next." Check the box next to "Manually configure server settings or additional server types." Click "Next." Choose "Internet Email." Click "Next."

    3 Enter your name and email address in the "User Information" fields. Under "Server Information," choose "POP3" from the drop down box. Type "pop.att.yahoo.com" into the "Incoming Mail Server" field. Type "smtp.att.yahoo.com" into the "Outgoing Mail Server" field. Enter your user name and password into the "Logon Information" fields. This is the login information you use to access your webmail. Check the box to remember your password. Click the "More Settings" button.

    4 Select the "Outgoing Server" tab.  Check the box next to "My outgoing server (SMTP) requires authentication." Click the radio button next to "Use same settings as incoming mail server."

    5 Select the "Advanced" tab.  Check the box next to "This server requires an encrypted connection (SSL)." The field number should automatically change to "995." If it doesn't, change the field number to "995."

    6 Change the "SMTP" field to the number "465" and select "SSL" from the drop-down box. Click "OK." Click the "Test Settings" button to make sure that everything works correctly.

    7 Click "Next" and then "Finish."

    George Hua
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Friday, August 16, 2013 3:06 AM
    Moderator

All replies

  • Is your Outlook set to send immediately or not?

    If not, sending would require a second step of calling send/receive. The call would be to NameSpace.SendAndReceive(displayDialog), where displayDialog is a Boolean.

    When you look at an item in Outbox if it's italicized the item has been submitted to the Outlook mail transport. If not shown in italics either it was not submitted or the submittal was aborted. Opening or touching the item from the object model will abort the submittal.


    Ken Slovak MVP - Outlook

    Thursday, August 15, 2013 2:38 PM
    Moderator
  • Hi Petun.

    Could you send email successfully through Outlook manually?

    If not, I’d like you to check you Outlook setting and make sure you can send email through Outlook. I’ll also recommend you to post your question to Outlook IT Pro Discussions forum if you have any issue on using Outlook.

    If you can not connect to AT&T webmail, I would like you to check the settings in outlook from the below steps:

    1 Open Microsoft Outlook. Outlook 2010 users need to click on "File" on the top menu bar. Choose "Info" and then "Account Settings." Choose "Account Settings" again. Outlook 2007 users need to click "Tools" on the top menu bar. Select "Account Settings" from the list.

    2 Select the "Email" tab.  Click the "New" button. Click the radio button next to "Microsoft Exchange, POP3, IMAP, or HTTP." Click "Next." Check the box next to "Manually configure server settings or additional server types." Click "Next." Choose "Internet Email." Click "Next."

    3 Enter your name and email address in the "User Information" fields. Under "Server Information," choose "POP3" from the drop down box. Type "pop.att.yahoo.com" into the "Incoming Mail Server" field. Type "smtp.att.yahoo.com" into the "Outgoing Mail Server" field. Enter your user name and password into the "Logon Information" fields. This is the login information you use to access your webmail. Check the box to remember your password. Click the "More Settings" button.

    4 Select the "Outgoing Server" tab.  Check the box next to "My outgoing server (SMTP) requires authentication." Click the radio button next to "Use same settings as incoming mail server."

    5 Select the "Advanced" tab.  Check the box next to "This server requires an encrypted connection (SSL)." The field number should automatically change to "995." If it doesn't, change the field number to "995."

    6 Change the "SMTP" field to the number "465" and select "SSL" from the drop-down box. Click "OK." Click the "Test Settings" button to make sure that everything works correctly.

    7 Click "Next" and then "Finish."

    George Hua
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Friday, August 16, 2013 3:06 AM
    Moderator
  • Thanks for the detailed reply, and please forgive me for not reporting sooner that I finally got Outlook properly configured yesterday with the help of my ISP, att.net. As it turned out, the values they told me to enter were actually different from the ones you suggested. For example, their receiving and sending server names are inbound.att.net and outbound.att.net, respectively. However, your set of instructions prompts a question I hope you might answer to help my comprehension of this process: The 995 and 465 port numbers were exactly the ones they told me to enter. Did you just happen to know that those are the values used by att.net, or do those values have some special significance common to all or a majority of ISPs?


    Peyton

    Friday, August 16, 2013 3:55 AM
  • Hi Petun.

    Thanks for your reply.

    Could you send e-mails by Outlook manually now?

    If not, as I mentioned above. I suggest you to post your question to Outlook IT Pro Discussions.

    In addition, you can also consult AT&T webmail to get support.


    George Hua
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, August 16, 2013 10:16 AM
    Moderator
  • Actually, it's stopped working. Earlier I was sending messages both to myself (received on my AT&T webmail client) and to another party via automation of Outlook from within Visual FoxPro. Now I can't even send e-mail to myself manually using the graphic interface in Outlook. Everything goes to the Outbox, and when I click Send All again and again, nothing happens.

    I went through your (George Hua) list of configuration steps all over again, but keeping the inbound and outbound server names I had been given by tech support at AT&T (inbound.att.net and outbound.att.net) while choosing 'server requires encrypted connection (SSL)' which had not been chosen previously. The result was that it passed Outlook's "Test Connection" test and the automatically sent e-mail duly appeared in my AT&T webmail., but e-mails I send manually still go straight to the Outbox and don't get sent.

    Then I tried it again using the inbound and outbound server names you suggested. These, too, passed the "Test Connection" test and the automatically sent e-mail duly appeared in my AT&T webmail. But the result was the same: the message goes to my Outbox, not to its intended target.

    Any ideas?


    Peyton

    Friday, August 23, 2013 5:19 PM