locked
Can't get to Access Services application from internet RRS feed

  • Question

  • I have a small Access 2010/Sharepoint 2010 Access Services application which I can run from any pc on the lan. However when the app url browsed to from outside the lan, the site errors out. The main sharepoint site is accessible from outside the lan, after providing the appropriate login credentials. What could be causing this issue? Same login is used on the lan and if coming at the site from the internet.

    If I try to access the application root

    http://mainurl.com/app

    the error message for the hybrid access services app is simply "An error has occurred" (before I set up a default webform I got the same error as below)

    If I try to access the app management page like so:

    http://mainurl.com/app/_layouts/accsrv/ModifyApplication.aspx

    then:

    Error An unexpected error has occurred. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: b3f08c7e-8353-492e-9bbd-762b2a99d971

    Anyone have ideas on this?

    • Moved by Serge Luca [MVP]MVP Tuesday, June 22, 2010 4:19 PM configuration or setting problem (From:SharePoint 2010 - Using Visual Studio with SharePoint and other programming)
    Tuesday, June 22, 2010 4:26 AM

Answers

  • I know you can get the external site via the FQDN. This is due to the configuration wizard not configuring a Host Header for the IIS WebSite.

    This does not mean that using the FQDN is supported by this configuration, its obviously not working. In additon, you will recieve topology errors in your event log related the SharePoint configuration not having an entry for the FQDN your using.., The subsite is not enetered just the FQDN, AAM will not accept a SubSite.

    The FQDN of your WebApp as an example: http://www.mydomain.com needs to be entered as an Allternate Access Mapping for you to access (use) your site via the Internet that is using Access Web Services.

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    • Proposed as answer by Chris McNulty Tuesday, June 29, 2010 4:38 AM
    • Marked as answer by rusticloud Wednesday, July 7, 2010 1:17 AM
    Tuesday, June 29, 2010 12:54 AM

All replies

  • I'm not sure moving the post to this forum was a good idea. Access Services is pretty new, and the forum I posted in was supposed to be supporting that technology. If I get some help with this issue here that'd be great of course.
    Wednesday, June 23, 2010 3:23 PM
  • I'm not getting any help with this issue and Serge has not responded re moving this post back to the forum I originally posted to. I'll wait another day or so and then post again in the original forum if there is no action here.
    Friday, June 25, 2010 1:55 PM
  • There's no dedicated Access Services forum so far and it's hard to get Access SMEs to answer your question, even in the dev forum. However you may want to look into the ULS log with the correlation ID it displayed. Check the error messages related in the ULS log, and post them back to this post.
    Saturday, June 26, 2010 2:41 AM
  • OK, these are errors, with some url munging. I tried to browse to the applicaiton root and then to the app management page.

    06/26/2010 08:21:08.63    w3wp.exe (0x0ECC)    0x0E58    SharePoint Foundation    Web Parts    emt4    High    Error initializing Safe control - Assembly:Microsoft.Office.SharePoint.ClientExtensions, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c TypeName: Microsoft.Office.SharePoint.ClientExtensions.Publishing.TakeListOfflineRibbonControl Error: Could not load type 'Microsoft.Office.SharePoint.ClientExtensions.Publishing.TakeListOfflineRibbonControl' from assembly 'Microsoft.Office.SharePoint.ClientExtensions, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'.    b7f073d4-2558-4a89-9d08-14176479c065

    -------------

    Alternate access mappings have not been configured.  Users or services are accessing the site http://myserver with the URL http://22.222.222.222.  This may cause incorrect links to be stored or returned to users.  If this is expected, add the URL http://22.222.222.222 as an AAM response URL.  For more information, see: http://go.microsoft.com/fwlink/?LinkId=114854"/>

    --------------

    06/26/2010 08:21:08.77    w3wp.exe (0x0ECC)    0x0E58    SharePoint Foundation    Runtime    tkau    Unexpected    System.ArgumentException: List 'MSysASO' does not exist at site with URL 'http://22.222.222.222'.    at Microsoft.SharePoint.SPListCollection.GetListByName(String strListName, Boolean bThrowException)     at Microsoft.Office.Access.Server.UI.ModifyApplication.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)    b7f073d4-2558-4a89-9d08-14176479c065
    Saturday, June 26, 2010 3:34 PM
  • have you setup AMM? It may be necessary for your internet access depending on your configuration.
    Sunday, June 27, 2010 8:01 AM
  • No I have not set up anything in AMM. I have attempted that now but every resource that discusses that on the microsoft site seems to refer to the previous edition of sharepoint. It would be a lot more helpful if the resources offered were current, obviously. For example the url in one of the error messages in my earlier post is out of date. I can't map any of the instructions I've found to what sharepoint 2010 offers. I've tried a couple of things without success. I'm not eager to add a lot of mappings to the server at random without knowing if I'm enabling what is needed, or if I'm just twisting this sharepoint instance into some odd shape.

    My case should be extremely simple. How can I have the application work via an internet url rather than a intranet url?

    Sunday, June 27, 2010 3:33 PM
  • Hi,

    You will need AAM unless the Outside URL is the same as the internal address.  

    Open Central Admin, Click on Configure alternate access mappings > Click on Edit Public URLs the URL in your address bar http://YourCentralAdminSite/_admin/EditOutboundUrls.aspx > From the drop down on the right: Alternate Access Mapping Collection, Choose the WebApp that you want to modify > add http://mainurl.com to the Internet Zone > Click Save

    Once you have verified that this resolves your issue, the best practice is to extend your WebApp. I would nomally do this first but I didnt want to add any additional points of failure until we have resolved your first issue.

    From Central Administration > Click Application Management > Highlight You WebApp > Click Extend >Create a new IIS web site Enter mainurl.com.EXT, Port ?? , HostHeader mainurl.com, Public URL http://mainurl.com, Zone Extranet, and click  OK

     

    Cheers,

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Monday, June 28, 2010 9:38 AM
  • Ivan thank you for those clear instructions.

    But the Access Services application does now show as a WebApp (there are only two listed, Sharepoint - 80 and Central Admin on 23532). I've hunted through quite a few of the sharepoint Central Admin menus but I cannot find the Access Services apps listed anywhere. So I can't actually complete the steps you've outlined, either part A or part B.

    The Access Services app can be managed if I go directly to it's url: http://myserver/myapp. Note that url uses port 80 not the port that central management is on. From the sharepoint home site on port 80, if I show All Site Content I can see my Access Services apps listed under Sites and Workspaces. But how do I allow them to be exposed via the external url?
    Monday, June 28, 2010 2:30 PM
  • Hi Rusti,

    Access Services is not a WebApp,

    Looks like it would be the SharePoint 80 WebApp that is hosting Access Services where you would need to modify your AAM settings and add the FQDN http://MyServer.MyDomain.com.

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Monday, June 28, 2010 6:45 PM
  • I tried something like what you suggested, but no success so far.

    I'm at the Edit Public Zone URLs page; in the right hand corner it says

      Alternate Access Mapping Collection:   SharePoint - 80

    Default says http://myserver

    Intranet says http://myserver

    Internet says http:/www.mydomain.com/myapp

    The other two fields I've left blank. But when I try to save it I get

    The URL format was invalid.
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 123d908a-91c6-458f-b7e5-cbf8abe86ef0


    Any ideas?

    Monday, June 28, 2010 7:57 PM
  • Dont use a subsite remove /myapp also its 2 // after : should look like this http://www.mydomain.com

     

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Monday, June 28, 2010 8:31 PM
  • The missing forwardslash was just a typo here in my posting.

    I think the subsite has to be there. The Access Services app is not the main website. The main website, http://www.mydomain.com, is fully accessible via browser after plugging in the sharepoint user credentials. It's only the Access Services app that fails with the messages I posted above. Not sure if you read this thread from the beginning but that's the original issue - the main sp website is ok, only the Access Services app fails.

    Monday, June 28, 2010 11:27 PM
  • I know you can get the external site via the FQDN. This is due to the configuration wizard not configuring a Host Header for the IIS WebSite.

    This does not mean that using the FQDN is supported by this configuration, its obviously not working. In additon, you will recieve topology errors in your event log related the SharePoint configuration not having an entry for the FQDN your using.., The subsite is not enetered just the FQDN, AAM will not accept a SubSite.

    The FQDN of your WebApp as an example: http://www.mydomain.com needs to be entered as an Allternate Access Mapping for you to access (use) your site via the Internet that is using Access Web Services.

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    • Proposed as answer by Chris McNulty Tuesday, June 29, 2010 4:38 AM
    • Marked as answer by rusticloud Wednesday, July 7, 2010 1:17 AM
    Tuesday, June 29, 2010 12:54 AM
  • I'm sure you're right but I still have something wrong. After removing the subsite so that the url for internet is

    http://www.mydomain.com

    I get this error when I try to save:

    You must specify the default zone URL for all Web applications. To delete the Alternate URL Collection, remove the public URLs in all other zones, and then remove the default zone URL.

    I have no idea how what that all means...thank you for persisting with this.

    Tuesday, June 29, 2010 1:08 AM
  • This is not resolved - I hope someone can help me get it working.
    Thursday, July 1, 2010 1:46 PM
  • Cool...got it working. Everything you said was right; I'm not sure why it worked this time without error.

    To wrap up this long thread, in order to allow the Access Services app to be available via a public url,

    1. open central administration
    2. chose "Confiigure alternate access mappings"
    3. chose "edit public zone urls"
    4. Select Sharepoint - 80 from the "Alternate Access Mapping Collection" dropdown list. If that entry is not shown, chose "Change Alternate Access Mapping Collection" and select it in the popup that opens
    5. Enter Default: http://myserver and Internet http://www.mydomain.com.
    6. Save

    At that point the Access Services app could be reached from a public url. It's been a week since my prev attempt so I don't know for sure why it didn't work. I may have had an intranet entry in there that created the last reported error.

    Anyways thanks Ivan.

    Wednesday, July 7, 2010 1:16 AM