none
MSI getting corrupted during XCOPY to Windows 2008 R2 Server RRS feed

  • Question

  • We compile C++, C# code to generate binaries that are later packaged into an MSI. In this program, we generate 10+ MSI packages each with varying sizes and contents. These MSIs are generated in Windows 8/8.1 TFS 2012 build slaves and are copied to a central file share location from where users consume these installers; the central file share is running on a Windows 2008 R2 server. This central file share has an official version of McAfee virus scanner configured and running all the time.

    Out of these 10+ installers (MSI) one of the installer holds some MP4 contents compressed and packaged into an MSI. This file is signed using our corporate certs and is copied to the central file server.

    While the file on the source machine (where it is generated) is intact; the file gets tampered when it is copied to the central file share. When we attempt to install the file it throws an error (attached). The file copy is handled programmatically using XCOPY. Again, this issue is intermittent, meaning the file is not getting tampered every time we attempt to copy to the central file share. When the file is altered, we could see some binary blocks are modified.

     

    Here are some of the items that we tried to get to the root of the issue

    • Attempted      all relevant options in using XCOPY (there are 26 different      parameters/arguments that you can provide while doing a XCOPY)
    • Attempted
           BINARY COPY (XCOPY does only ASCII copy)
    • Attempted      duplicate copy, while this is just a workaround, we still have not figured      out the root cause
    • Attempted      MD5 checksum, while this tells that the file has been corrupted, it does      not tell why
    • Attempted      signing the MSI, again this tells if the file has been corrupted but not      why
    • Attempted      copying to a different location other than the central file share; this      seems to work so far
    • As a      workaround, we have given share access on the build machine itself. There      is no copy involved here preventing file tampering.
    • Ran      manual McAfee virus scan on the central file share and the source file      from the build system. McAfee logs looks identical and does not reveal      anything.

    While most of the options are related to workarounds, we are moving in a direction to figure out the root cause. There are questions on why this is happening to only one particular file and not on other MSIs. Is the media content within the MSI getting impacted due to the virus scan?

    At the moment  I am running out of ideas and need some help from someone who might have experienced similar issues. Has anyone seen this issue before?

    Thank You

    Elango Senthilnathan

    Tuesday, August 26, 2014 5:40 AM

All replies

  • We tried ROBOCOPY and that seems to be better than normal COPY or XCOPY. Even ROBOCOPY fails at times and cant trust it entirely. Does anyone had similar issues?

    We have narrowed down that the issue is happening only while copying the file from a VMware build slave/agent to another VM file share. Read some forums saying that VNic might cause file corruptions, don't know how far that is true. We are running VMware 5.1; may be need to upgrade it to 5.5 to get the latest VNIC drivers.

    Monday, September 15, 2014 9:47 PM