none
How to populate AS2 Message Date Time RRS feed

All replies

  • Sounds like a pipeline component to set the value if it is missing. This one seems simple enough that they would make a hotfix for it.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Friday, August 27, 2010 1:28 AM
    Moderator
  • Hi Dan,

    There is No send side configuration Setting for adding Date header in the As2 Headers,

     

    I don't understand the question

     

    Is it,

    1. You want to get the DateTime of the Send As2 Message ?

    2. You want to get the Date time of the Received As2 Message ?

    3. You want to send the Date Time in a As2 Message as a Header ?

    Please Clarify and we can move forward,

    Chibi

    Monday, August 30, 2010 2:25 PM
  • So here's the issue.  Doing some AS2 testing with BizTalk.  When I send messages from my development BizTalk machine to an installed BizTalk sever, using the AS2 Pipelines to send on my dev machine as well as to receive on the server, I get no data in the AS2 Message Date Time column of the AS2/MDN Status view (in the admin console). 

    Same receive location receives messages from another party, in this case Amazon, it populates this field. 

    I am not even handling EDI in this solution, just AS2. 

    Again, BizTalk Server 1 to BizTalk Server 2 = no AS2 Message Date Time in the admin console (btw, turned on AS2 Reporting)

    Amazon.com to BizTalk Server 2 gives me AS2 Message Date Time. 

    Version is BT 2009 all around.  I have no idea what Amazon runs. 

    Ultimately I want: 2. You want to get the Date time of the Received As2 Message ?

    But the problem seems to me not to be in the Receiving, which works fine for Amazon, but in the BizTalk sending, which would be 3. You want to send the Date Time in a As2 Message as a Header ?

    Kind Regards,

    -Dan

    Monday, August 30, 2010 3:31 PM
  • I see that this is a New Feature requirement + a know issue fix, 

    Please open a MSConnect Issue and we will look in to this. There is I think another QFE, we did for Datetime in the message I will look into that and send you a KB Article number if it is for BTS2009. 

    Thanks for your Patience,

    Chibi

    Wednesday, September 1, 2010 1:20 PM
  • Yes, this is BT2009.  I can check later today if the same thing happens under 2010. 

    Kind Regards,

    -Dan

    Thursday, September 2, 2010 2:12 PM