locked
Sharepoint Site Logo Issue RRS feed

  • Question

  • Hello,

    I have been working on a page and I had set it up to inherit from the parent, however when the page displays in the browser you can quickly view the new logo then the page reverts to the SharePoint logo. I have been looking in designer where to update this and I had gone to the v4master (backup) to update this change. Now the page is updated in the designer, but still not in the browser. It appears that there is some over ridding taking place and I can't quite put my finger on where this is happening. I don't really want to mess with the master pages if I don't need to, but am willing to try just about anything to get this FINALLY working. This is the last thing for this page then it's up and running.

    Site Actions-> Site Settings-> Look and Feel-> Title, Description, and icon has been updated with the path where the logo is saved.

    Any ideas would be appreciated. Thank You


    Richell A. Grant

    Monday, April 8, 2013 4:06 PM

Answers

  • Here is what I did. In designer I selected the 'PlaceHolderPageTitleInTitleArea (Custom)' in the designer on the 'Design' side and double clicked. A Web Part Page Title Bar Box popped up and this is where you can change the title, caption, description and image link to the page. I added a path to the image link, which allows me to put the path to my logo and then selected 'OK'. This solved the issue.

    Richell A. Grant


    • Marked as answer by R_Grant Monday, April 8, 2013 6:10 PM
    • Edited by R_Grant Monday, April 8, 2013 6:11 PM
    Monday, April 8, 2013 6:10 PM

All replies

  • Open site in SharePoint designer ->Master Pages from left nav -> On the current master page you were working right click & you'll see version history. That helps you to revert. 

    Regarding, the results you be able see in SPD but not in browser is mainly due to not checked-in &/or published major version.

    Hope this helps.

    Monday, April 8, 2013 4:13 PM
  • I checked everything in and refreshed, no changes. It is still showing the new logo in a second then reverting to the older one (sharepoints default). I noticed the default is in '_layouts/images/folder', but I am unable to get there to update or even re-route the path.

    Richell A. Grant

    Monday, April 8, 2013 5:03 PM
  • Hey,

    Change default name property of <SharePoint:SiteLogoImage /> in master page to override this behaviour.

    After changing name property it will look like name=”HeaderLogoCustomName”

    Thanks,
    Please mark it as an answer if it works.

    Monday, April 8, 2013 5:12 PM
  • I apologize, but I don't understand your comment. What am I supposed to change <SharePoint:SiteLogoImage /> to?

    This is the code in the master for this logo:

    The code for SPD 2010 Master Logo

    I hope you can help me with this. It would be nice to have this fixed before going home today.


    Richell A. Grant

    Monday, April 8, 2013 5:22 PM
  • Replace this property ---> name="onetidHeadbnnr0" to something like --> name="HeaderLogoCustomName"

    You can specify your name instead of that i have given.

    Thanks.Please mark it as an answer if it works.

    Monday, April 8, 2013 5:29 PM
  • Ok, I did that but when refreshing the page I can see the logo for a quick second and then it goes back to the sharepoint default logo. :( And I did make sure the pages were saved and checked in before refreshing.

    Richell A. Grant


    • Edited by R_Grant Monday, April 8, 2013 5:34 PM
    Monday, April 8, 2013 5:34 PM
  • Here is what I did. In designer I selected the 'PlaceHolderPageTitleInTitleArea (Custom)' in the designer on the 'Design' side and double clicked. A Web Part Page Title Bar Box popped up and this is where you can change the title, caption, description and image link to the page. I added a path to the image link, which allows me to put the path to my logo and then selected 'OK'. This solved the issue.

    Richell A. Grant


    • Marked as answer by R_Grant Monday, April 8, 2013 6:10 PM
    • Edited by R_Grant Monday, April 8, 2013 6:11 PM
    Monday, April 8, 2013 6:10 PM