locked
SSIS - "Sensitive" Project parameter - Usage in package RRS feed

  • Question

  • Hi,

    I have 

    1) A project level parameter in my SSIS project, which has "Sensitive" set to true.

    2) I have a variable within the the package in the project.

    I want to be able to assign this "sensitive project parameter" to the variable in the package, in expression.

    At the moment it does not allow me to do it, and throws an error.

    How can I do this ?


    • Edited by SQLDev555 Wednesday, October 14, 2015 2:29 PM
    Wednesday, October 14, 2015 2:29 PM

Answers

All replies

  • HI SQLDev198155,

    This thread may be the answer on how.


    Arthur

    MyBlog


    Twitter

    Wednesday, October 14, 2015 2:45 PM
  • There is no option to "parameterize" a variable in SSIS package.
    Wednesday, October 14, 2015 2:53 PM
  • Use the Expression builder


    Arthur

    MyBlog


    Twitter

    • Proposed as answer by Harry Bal Wednesday, October 14, 2015 8:40 PM
    • Unproposed as answer by SQLDev555 Wednesday, October 14, 2015 8:42 PM
    Wednesday, October 14, 2015 3:02 PM
  • Are your package parameters set to "Sensitive" ??


    • Edited by SQLDev555 Wednesday, October 14, 2015 3:26 PM
    Wednesday, October 14, 2015 3:23 PM
  • I want to be able to assign this "sensitive project parameter" to the variable in the package, in expression.


    You don't need to assign it back. You can directly reference the project parameter in your package such as I expression builder etc.

    Thanks, hsbal

    Wednesday, October 14, 2015 8:41 PM
  • You cannot use  a project parameter (marked as sensitive) , in the expression builder of a package variable. 

    Wednesday, October 14, 2015 8:41 PM
  • You cannot use  a project parameter (marked as sensitive) , in the expression builder of a package variable. 

    Use script task if you need it the way you are saying

    http://www.mattmasson.com/2012/01/retrieving-the-value-of-a-sensitive-parameter-in-a-script/


    Thanks, hsbal

    Wednesday, October 14, 2015 8:54 PM