locked
WinJS.xhr can't call web services in local machine or internal network?

    Question

  • Hello guys.

    I've noticed that I can't get to any Web service if they're not published on the web. Can anyone please tell me if this is a bug? Why does this limitation exist? I understand that allowing access to localhost is not something you'd want, but why can't I get access to Web services published in my internal servers? Does this mean that I can't build a Windows 8 metro app which gets data from the intranet? this can't be right...


    Luis Abreu
    Thursday, January 05, 2012 9:54 AM

Answers

All replies

  • Partially solved: intranet services require the home/work networking capability.

    Now, I still need to access the Web service hosted in my machine. I've tried using the checknetisolation.exe tool but it still doesn't work. btw, here's the command I've run:

    checknetisolation loopbackexempt -a -n=win8tests_t2ggmrgk4m9fg

    (I've went into the manifest and I've used the name from the Package Family Name option of the packaging tab)

    running the checknetisolation loopbackexempt -s, I can see that the rule was added:

     

    PS C:\Windows\system32> checknetisolation.exe loopbackexempt -s

    List Loopback Exempted AppContainers

    [1] -----------------------------------------------------------------
        Name: win8tests_t2ggmrgk4m9fg
        SID:  S-1-15-2-1674486189-1466792130-3787983069-2874228640-3598662651-1300429485-2157798256

    PS C:\Windows\system32>

     

    Unfortunately, I still can't get the data from my app.

    I've only managed to get the data from my service by opening fiddler2: after doing that, my local service is invoked and everything works as expected.

    any thoughts??

    thanks.


    Luis Abreu
    Thursday, January 05, 2012 12:38 PM
  • Thursday, January 05, 2012 1:49 PM