none
Error in Web Performance and Load test project

    Question

  • Product -

    Visual Studio Ultimate 2013

    Version 12.0.31101.00 update 4

    Dot Net framework 4.5

     

    Problem- We created "Web Performance and Load test project" to create load test of website using Visual Studio online. It works fine for http sites. However we are consistently getting following errors for https site. These sites are working fine through normal browser operations.

     

    https site without load balancer. Error - Request failed: An existing connection was forcibly closed by the remote host

    https site with load balancer. Error - Request failed: The server committed a protocol violation. Section=ResponseStatusLine

     

    It will be very helpful if you can provide some inputs about resolving these errors. 

    Thursday, September 01, 2016 6:59 AM

Answers

  • Hi Manish Dhotre,

    This issue may be caused by different reasons, please refer to the following scenarios to troubleshoot your issue:

    1). Please run the web per test separately and during the running, please set the run iteration more than once. To observe whether this issue occurs. If it reports this issue again, please Check whether has dynamic data in the request. The way to fix non-detectable dynamic parameters in web per test please refer to the following MSDN document:

    https://msdn.microsoft.com/en-us/library/ff460245.aspx

    2). If it works fine in web per test, but failed in load test. This may be caused by the server limits your request. We could try use connection pool for Web test connection model during load test.

    Click Run Settings[Active] in load test->in properties panel set WebTest Connection Model property as Connection Pool

    3). Please set the Proxy in web test as default. And change the TLS version. Please refer to the following link to set you TLS version.

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/bc3ebf23-575d-4e54-bd6b-a1ed87fe5213/web-performance-test-is-not-working-with-tls12-enabled?forum=vstest

    or disable the TLS1.2 in IE. Please refer to following steps:

    Tools->Internet options-> Advanced-> uncheck Use TLS 1.2, please refer the following screenshot:

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 02, 2016 6:23 AM
    Moderator