none
Bizarre error when creating linked service to on premises SQL

    Question

  • Hi!

    When creating a connection to on-premises SQL server cryptic error "Error: Response with status: 401 Unauthorized for URL: https://s2.datafactory.ext.azure.com/api/V2query2/EncryptData" is shown. I found some post that this should be fixed. However, it is still occurring to me. Any ideas how to get past this?

    

    Best regards,

    Martin

    Tuesday, September 4, 2018 8:04 PM

Answers

  • Hi!

    Region is west europe and self hosted runtime. I just tried again and the error is gone. I'm guessing it had something to do with the massive distruption in Azure services 10h ago.

    Thanks for help

    • Marked as answer by Martin_Tints Wednesday, September 5, 2018 8:12 AM
    Wednesday, September 5, 2018 6:42 AM

All replies

  • Hi Martin, 

    What is your data factory region? Is your self hosted IR online?

    Wednesday, September 5, 2018 2:22 AM
  • Hi!

    Region is west europe and self hosted runtime. I just tried again and the error is gone. I'm guessing it had something to do with the massive distruption in Azure services 10h ago.

    Thanks for help

    • Marked as answer by Martin_Tints Wednesday, September 5, 2018 8:12 AM
    Wednesday, September 5, 2018 6:42 AM
  • Hi Martin,

    If you have any resolution related to Error: Response with status: 401 Unauthorized for URL: https://s2.datafactory.ext.azure.com/api/V2query2/EncryptData.Can you Please share the link.

    Wednesday, September 5, 2018 1:15 PM