none
Visual Studio Losing My SSIS Packages?

    Question

  • This has became a frequent occurrence when editing .dtsx files in a BIDS project.   I create an SSIS package, get it working, save it, then when i come back to it later and open it, it is blank.  And no it has nothing to do with the designer not being sized right.  I can right click on the package and do a view code and the xml comes up.  But there is no name on the tab at the top of the designer and the xml is black and doesn't look like normal package code.  See screen shot below.

    If I copy the package to another name it will work correctly.  Sometimes I can delete the original and rename the copy and it will go back to working correctly.  Other times it does not.

    This happens to projects that are under source control in Team Foundation Server and those that are not. 

    Any ideas or help is appreciated.

    Thanks

    Tuesday, March 14, 2017 2:03 PM

All replies

  • Hi Eric_ht,

    Welcome to MSDN forum.

    Please tell me the version of your visual studio and Team Foundation Server.

    >>This happens to projects that are under source control in Team Foundation Server and those that are not.

    Do you mean that you will meet the situation when you connect to TFS and everything is ok without TFS connection?

    Please check it with the other type of project and see if the issue persists with/without TFS connection.


    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, March 15, 2017 7:34 AM
  • Thanks Joyce.  Below is the VS info.  I am unsure of the TFS version at this time. 

    And No, I meant the issue occurs with projects under Source Control in TFS and to projects not under Source Control.  In other words it happens either way and appears to be strictly a Visual Studio problem.  Sometimes I can restart Visual Studio and it will clear up the problem.  Other times it does not.

    Thanks again.

    Microsoft Visual Studio Professional 2013
    Version 12.0.40629.00 Update 5
    Microsoft .NET Framework
    Version 4.5.50938

    Installed Version: Professional

    LightSwitch for Visual Studio 2013   06177-004-0446025-02004
    Microsoft LightSwitch for Visual Studio 2013

    Team Explorer for Visual Studio 2013   06177-004-0446025-02004
    Microsoft Team Explorer for Visual Studio 2013

    Visual Basic 2013   06177-004-0446025-02004
    Microsoft Visual Basic 2013

    Visual C# 2013   06177-004-0446025-02004
    Microsoft Visual C# 2013

    Visual C++ 2013   06177-004-0446025-02004
    Microsoft Visual C++ 2013

    Visual F# 2013   06177-004-0446025-02004
    Microsoft Visual F# 2013

    Visual Studio 2013 Code Analysis Spell Checker   06177-004-0446025-02004
    Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

    Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

    The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

    Application Insights Tools for Visual Studio Package   1.0
    Application Insights Tools for Visual Studio

    ASP.NET and Web Tools   12.5.60612.0
    Microsoft Web Developer Tools contains the following components:
    Support for creating and opening ASP.NET web projects
    Browser Link: A communication channel between Visual Studio and browsers
    Editor extensions for HTML, CSS, and JavaScript
    Page Inspector: Inspection tool for ASP.NET web projects
    Scaffolding: A framework for building and running code generators
    Server Explorer extensions for Microsoft Azure Web Apps
    Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Microsoft Azure

    ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
    For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

    ASP.NET Web Frameworks and Tools 2013   5.2.30612.0
    For additional information, visit http://www.asp.net/

    Common Azure Tools   1.4
    Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

    Microsoft Azure Mobile Services Tools   1.4
    Microsoft Azure Mobile Services Tools

    NuGet Package Manager   2.8.60610.756
    NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

    Office Developer Tools for Visual Studio 2013 ENU   12.0.30626
    Microsoft Office Developer Tools for Visual Studio 2013 ENU

    PreEmptive Analytics Visualizer   1.2
    Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

    SQL Server Analysis Services   
    Microsoft SQL Server Analysis Services Designer
    Version 12.0.2000.8

    SQL Server Data Tools   12.0.41012.0
    Microsoft SQL Server Data Tools

    SQL Server Integration Services   
    Microsoft SQL Server Integration Services Designer
    Version 12.0.2430.0

    SQL Server Reporting Services   
    Microsoft SQL Server Reporting Services Designers
    Version 12.0.2430.0

    Windows Phone 8.1 SDK Integration   1.0
    This package integrates the tools for the Windows Phone 8.1 SDK into the menus and controls of Visual Studio.

    Workflow Manager Tools 1.0   1.0
    This package contains the necessary Visual Studio integration components for Workflow Manager.

    Thursday, March 16, 2017 1:09 PM
  • Hi Eric_ht,

     

    >> This has become a frequent occurrence when editing .dtsx files in a BIDS project.  I create an SSIS package, get it working, save it, then when i come back to it later and open it, it is blank. 

    Does this only happen to this specific project or other projects as well? You could create some other types of project to check it.

    Not sure where you store the package, it’s also probably cause related to physic environment, then I suggest you create a new one which’s stored in another different location, under another disk path if it’s possible.

     

    Please also check if you’ve got any antivirus software, if so you would turn it off or add the files generated by VS IDE to trusted, and then give it a try.

     

     

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, March 17, 2017 9:25 AM
  • I don't work with a lot of other project types so I can't say if it happens there or not.  I mainly work with SSIS and BIDS projects.

    The only antivirus we run is the Microsoft System Center Endpoint Protection. 

    I have changed locations before to no avail.  For TFS based projects I have even changed workspaces between local and server. 

    Friday, March 17, 2017 7:45 PM
  • Hi Eric_ht,

    Thank you for your update.

    Have you make any changes to visual studio?

    please click Tools-Import and Export Settings to reset all settings for your visual studio. Or you could import an environment setting which is exported before you get the issue.

    Meanwhile, you could repair visual studio via control.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 20, 2017 7:19 AM
  • I tried doing a repair and reset settings back to default.  It had not happened since I opened this post so i was beginning to think these two things may have solved it.  But it happened again today....
    Thursday, March 30, 2017 7:25 PM
  • Hi,

    Thank you for your update.

    Please reset settings again and open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE and run the command: devenv /resetuserdata

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 31, 2017 8:15 AM
  • To all:

    We have several ETL developers who have the problem.  It appears to happen to us when we have worked on a project for several hours.  Even though we are repeatedly saving our changes, at some point, the designer window goes blank, and we cannot see our .dtsx packages any more.  Closing Visual Studio and reopening it will get the visibility back.  Of course, we do this after a few choice words are uttered.

    We are using VS 2015 Enterprise version 14.0.25431.01 Update 3


    Paul LaGrone

    Thursday, July 19, 2018 2:02 PM