locked
Unable to successfully publish project RRS feed

  • Question

  • Hi,

    I have a relatively simple application where a good contractor put together in Visual Studio things that I am incapable of doing.  It basically consists of adding a few Windows forms containing specialized instructions for use at the start of an open-source program.

    After some fine-tuning that I was able to do on my own, the hybrid application opens and runs correctly and well when opened from the appropriate bin folder in the cloned application folder.  Now I just need to publish that so select other people can install and inspect the application on their devices.  I am unable to accomplish this thus far (noting that while I can do a limited amount I am not a programmer by any means).

    I am starting with something simpler first, that of trying to use the one-click publishing process and publishing the application to where it can be installed from a CD or comparable media rather than through online means.  I will add here that I am first trying this publishing process purely with just the original open-source program, not even adding in my forms yet (in other words cloning the open-source program and turning it right back around and publishing it so that it can be installed as a functioning application on a computer).  I am not even able to successfully do this.

    The publishing process "seems" to go okay and I get a setup icon and other relevant files, and when subsequently trying to install from that the application "seems" to install.  But when done it will not open, commonly just getting a brief view of the open-source program splash screen before disappearing and never opening to the actual application.

    Among other things I have noticed that there always seems to be a duplicate installation folder automatically created and called app.publish, at times getting prompts that I cannot open the application at all because another instance of it already exists and might be open elsewhere on the computer.  To try to simplify certain things some, I have tried to turn off security settings for this one-click publishing thing, but it always seems to reactivate itself when trying to publish the application again.

    Any guidance regarding this particular matter would naturally be appreciated.  Thank you very much.

    Monday, June 29, 2020 3:39 PM

All replies

  • Hi BK WW,
    >>trying to use the one-click publishing process and publishing the application to where it can be installed from a CD or comparable media rather than through online means.
    I noticed that you choose to publish to a CD-ROM or DVD-ROM, so you can refer to following steps below:
    1. In the  Project Designer, click the Publish tab ->Publish Wizard button.
    2. In the "Where do you want to publish the application?" page, enter the file path or FTP location where the application will be published. Then click Next to continue.
    3. In the “Where will the application check for updates?" page, choose an update option.
    4. Click Finish to publish the application.
    More details you can refer to this document.
    >>it always seems to reactivate itself when trying to publish the application again.
    Which update option you choose? If you choose "the application will check for updates from the following location", network connectivity is still required for application updates. Based on your description, I suggest you verify that the location that the URL is pointing to is correct. 
    Here is a related document.
    Best Regards,
    Daniel Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, June 30, 2020 2:48 AM
  • Hi Daniel,

    Thank you very much for your comments.  I really appreciate it.  I already found and tried the information you pointed to (along with many other links) before posting, but I certainly could have missed something so thank you again.

    Yes, I started by trying publishing where the application could be installed from a CD, which should be a simpler test than anything attempted through online means.  I have also initially chosen to not check for any updates, which should also make for a simpler test.  But being able to publish, install, open, and run the application through the click once publishing feature under these conditions is still failing, even though it opens and runs fine through the application icon in the bin folder.

    I have made some small progress working with the versions feature and having that automatically advance, so now I can at least make any number of changes in various places and republish, reinstall, and retry to see if anything works, without getting prompts like I need to change the manifest or uninstall the application first because it already exists somewhere else on the machine and might be open.

    But beyond that there has unfortunately been no progress, with nothing at all happening when trying to open and run the application after installation (or getting just a brief glimpse of a splash screen before it disappears), never opening to the actual application.

    In addition to me creating a folder in a convenient location to publish the application to, there still appears to be a second copy being automatically published in a newly created folder named app.publish (without my doing or knowledge until I stumbled upon it).  I do not know if this might have any relevance toward what is potentially going on (or not going on).  But any other possible suggestions from anyone would naturally be appreciated.  Thank you very much.

    Sincerely,

    Bill

    Tuesday, June 30, 2020 7:44 PM