locked
Application Verifier fails to initialize on Windows XP x64 RRS feed

  • Question

  • Hi,

    hope this is the right newsgroup for my question. If not, my apologies.

    I just installed the 64-bit standalone version of Application Verifier (v3.3, for x64  CPUs) on my system which runs Windows XP x64. I'm now trying to use it with a 64-bit application, but can't get Application Verifier to log anything.

    When I run my executable in the debugger, I see the following messages:

    AVRF: foo.exe: pid 0x1498: flags 0x80000000: application verifier enabled
    'foo.exe': Loaded 'C:\WINDOWS\system32\verifier.dll', Exports loaded.
    AVRF: failed to initialize verifier logging (C000003A).
    AVRF: verifier.dll provider initialized for foo.exe with flags 0x80000000

    The application starts up just fine - but there are no log files and no test results afterwards.

    I found an old posting in a newsgroup where somebody was trying to use the  64-bit version of Application Verifier with a 32-bit app, and also failed to  get any logs. However, in my case, both the Verifier and the app are 64-bit.

    Thanks for any help or pointers!

    Claus
    Friday, April 27, 2007 11:31 AM

Answers

  • Claus,

     

    Unfortunately, this forum is only for discussion regarding the Application Verifier feature that ships with Visual Studio, not the standalone tool.

     

    The newsgroup that you orginally posted to is the correct location.

     

    Regards

     

    David

    Friday, April 27, 2007 8:36 PM