locked
Windows 10 IoT Core Insider Preview Frequently Asked Questions (FAQ) RRS feed

  • General discussion

  • Windows 10 IoT Core Insider Preview Frequently Asked Questions (FAQ):

    Verify Connection to Device

    I’ve just booted my device and I can see that it’s running.  How can I verify that my development system or the VM can see and connect with the device before I try to use Visual Studio?

    The tool ‘Windows IoT Core Watcher’ is installed as part of the VHD and it will detected with a device is booted.  Alternatively you can open a web browser and enter the IP address of the device.  http://192.168.0.10 for example.  This brings you to the WebB interface that lets you manage and monitor the device, collect debugging information and other things.  You can also open this by right clicking on the device in Windows IoT Core Watcher and selecting ‘Web browser here’.

     

    Setting up Raspberry Pi

    My display doesn't look right, the screen appears cropped or stretched

    This can happen on some monitors. To work around this force the board into DVI mode (vs. HDMI mode). You can read more about this here. Mount the SD card to a local PC and proceed to edit the file in the EFIESP partition. For example if the partition is mark as H drive, edit H:\config.txt by adding the following line.

    hdmi_group=2 # forces DVI timing to be used

    Can I set up a Raspberry Pi 2 using Windows 8.1?

    You will need Windows 10 on your PC to be able to set up Raspberry Pi 2 running Windows 10 IoT Core.

    Why does my SD card have to be 8gb, do you really need all that space?

    The IoT Core image is under 1gb, the 8gb is meant to give you space to install additional content on your device.

    When I boot, neither my mouse nor keyboard appear to work?

    This is a known issue that some customers are observing with the current build.  The workaround is to leave them unplugged, boot, and then plug them in.  Sometimes only the keyboard will work but that should allow you to navigate on the device to test your Apps.

     

    UAP Apps

    Are true console apps supported on Windows IoT Core?

    True “console” apps aren’t really going to be supported for the IoT core OS, headless or not. You can still deploy and run a standard win32 console app here, it just won’t be connected to any on-device console. When running headless you should just get that black screen. When running headed the only supported UI is via the UAP UI stacks (XAML, HTML, DirectX).

     

      C++ Console Apps

    I’m able to deploy a UAP application to my device, but can’t get my native application to deploy?

    The steps to set up and deploy a native console application are slightly more involved than what is needed for a UAP application.  You will have to setup a number of items in the Project Properties -> Debugging tab, and also set the project to ‘Deploy’ in the Configuration Manager.  Detailed steps for both of these can be found in the MemoryTracker sample.

     

    I’ve deployed the MemoryTracker application but I’m not seeing any output?

    To see output from this sample you’ll have to establish a PowerShell connection to the device and then run the application in that console.

     

    Features

    Is WiFi supported on Windows IoT Core?

    We are in the process of getting WiFi ready, but it is not the build that is currently publically available.

    Is Bluetooth currently supported on Windows 10?

    We are in the process of getting Blutooth ready, but it is not the build that is currently publically available.

    Intel Galileo

    Can I run Windows 10 IoT Core on the Intel Galileo Gen 1 or Gen 2 board?

    We have no plans to bring Windows 10 to the Intel Galileo board at this time.

    Will you continue to support the Windows Developer Program for IoT for Galileo?

    We’ve been overwhelmed by the interest in our Windows 8.1 based program and appreciate all the incredible feedback the community has provided. While there will be no new feature development for the Galileo release we will continue to support this release for as long as significant community activity exists.

    Errors

    I’ve downloaded the RPi2.ffu image and tried to apply image from the administrator prompt using this command:
    dism.exe /Apply-Image /ImageFile:Rpi2.ffu /ApplyDrive:\\.\PhysicalDrive1 /SkipPlatformCheck
    I am getting the following error:
    c:\Temp>dism.exe /Apply-Image /ImageFile:Rpi2.ffu /ApplyDrive:\\.\PhysicalDrive1 /SkipPlatformCheck

    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031

    Error: 87

    The /applydrive option is not recognized in this context.
    For more information, refer to the help.

    You need to use DISM on Windows 10 and not Windows 8.1.

    I’m want to move files from a host computer onto the RP2 via the remote power shell session. I’ve tried making a shared folder on my host computer (allow access to “everyone”), but the RP2 remote session fails with what seems to be an access denied error when I try to copy from the host shared folder. Has anyone done this successfully or have a good suggestion for how to do this?

    if you're just trying to copy files across and not doing this as part of some PowerShell script you're authoring, you can do it without PowerShell. Can you try accessing your RPi2 from your local PC with "\\<ip>\c$" and does that work for your scenario. If you can't do that, you do have access issues.
    < /ip>



    Known Issues - Release Notes (6/25 build)


    This is a list of known issues that you might encounter and any work-around that might exist:

    http://ms-iot.github.io/content/en-US/win10/ReleaseNotes.htm


    Jonathan Tanner | Microsoft | Windows 10 IoT Core Insider Preview Support | This posting is provided 'as is' with no warranties and confers no rights.









    Wednesday, April 29, 2015 12:58 AM
    Moderator