none
SharePoint 2013 Update Welcome Page Error RRS feed

  • Question

  • Dears,

    I appreciate your help in the below issue:

    Whenever I try to change the welcome page of any publishing site in my site colloection I get error

    0x81020089 object not set to an instance of an object

    and this is happening whether I try from (Site Settings - Welcome Page) or from (SharePoint Designer "Set as Homepage").

    Knowing that there's nothing custom out there.

    Thank you.


    • Edited by M.Hijazi Wednesday, May 3, 2017 5:01 AM
    Tuesday, May 2, 2017 8:02 AM

All replies

  • Hi,

    Please check the steps below:

    1. Open your site using SharePoint designer and go to Site Pages, and add a new web part page, then do "Set as Home Page".

    2. Check whether your welcome page have some custom code and throw the exception.

    3. Check the ULS log to see the detail error message.

    https://www.microsoft.com/en-us/download/details.aspx?id=44020

    4. Use Fiddler to monitor the requests and responses.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, May 3, 2017 8:29 AM
    Moderator
  • Thanks for your reply.

    There's no custom code, while I am trying this on blank page. Also, same error I get from designer.

    There's nothing custom out there. And the same error I get when I try to disable wiki homepage feature.

    I'm sure it's from Sharepoint itself. I got Sharepoint 2013 sp1 june update.

    Wednesday, May 3, 2017 10:43 AM
  • Hi,

    Please check the ULS log to see the detail error message.

    For SharePoint 2013, by default, ULS log locates in
    "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\LOGS"

    We can use ULS log viewer to see the log: https://www.microsoft.com/en-us/download/details.aspx?id=44020

    Or try to do IISRESET, then check if it works.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, May 4, 2017 4:14 AM
    Moderator
  • NO solution yet.

    Thank you.

    Wednesday, May 24, 2017 5:20 AM