locked
Before master page renders why do I get these dialog boxes, are they errors? RRS feed

  • Question

  • Hello Community

        I created an "Empty SharePoint Project" in Visual Studio 2010 Ultimate - SharePoint 2010.

        I haven't seen a web.config file.

        Also In the projects "Properties" on the "Debug" tab, "Enable Debuggers" is disabled and there
    doesn't seem to be a way to enable the checkboxes so that I can select the "Enable unmanaged code
    debugging" checkbox.

        The application Builds successfully and Deploys successfully

        In the project all I have done is created a master page. 

        Next I will create an application page/content so that I can add controls to the master page
    from.

        The project runs so far and shows the <server name>:port>/default.aspx page
    but before it renders that page a dialog box with a message pops up states that:

    "Attaching the ProteusDebugEngine debugger to process '[9164] w3wp.exe' on machine  <server name> failed. Invalid pointer."

        When I click "OK" on that dialog box another dialog box pops up stating that:

    "Cannot debug some of the code in process w3wp.exe [9164]. See below for status.

        Trace code succeeded
        Workflow code failed. Debugger is not registered.

    Click OK to continue debugging the remaining code.  To disable debugging the failed type(s) of code
    in the future, change the corresponding setting in the project properties dialog."

        So the problem is since "Empty SharePoint Project" in Visual Studio 2010 Ultimate - SharePoint 2010 does not have a web.config file how do I get rid of the dialog boxes that are popping up?

        Fyi, remember after the dialog boxes go away the master page does appear.

        Thank you
        Shabeaut

     

    Thursday, October 25, 2012 9:22 PM

Answers

  • Hi Shabeaut,

    A "SharePoint Project" is a special project for SharePoint developing, it is not a web application, so there is no web.config.
    "Enable Debuggers" is disabled  by design.

    For the issue, "Attaching the ProteusDebugEngine debugger to process '[9164] w3wp.exe' on machine  <server name> failed. Invalid pointer" and the coming issue, it is generally caused by the w3wp.exe process is not ready finally.

    Generally, we use the following was to debug a solution:
    1. Right-click project, and then click Deploy to deploy the solution.
    2. Open the site manually
    3. Run Command Prompt(CMD), execute: cd /d "c:\windows\system32\inetsrv"
    4. List w3wp.exe processes: appcmd list wp, get the process id for the w3wp for the debugging site
    5. Go to Visual Studio, click menu "Debug" > "Attach to process..."
    6. Select the w3wp.exe that has the id we got from step 4. Please check "Show processes from all users" and "Show processes in all sessions"

    Thanks,
    Jinchun Chen


    Jinchun Chen
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff AT microsoft.com(Please replace AT with @)

    • Marked as answer by Qiao Wei Sunday, November 11, 2012 3:00 PM
    Monday, October 29, 2012 9:08 AM
  • In addition, I would suggest you updating VS to 2010 SP1:
    http://www.microsoft.com/en-us/download/details.aspx?id=23691

    Jinchun Chen
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff AT microsoft.com(Please replace AT with @)

    • Marked as answer by Qiao Wei Sunday, November 11, 2012 3:00 PM
    Monday, October 29, 2012 9:09 AM

All replies

  • Hi,

    Can you please tell me whether you have currently installed Visual Studio 11 Beta as well along with VS 2010 or might have previously installed VS11 beta along with VS2010 already on your machine. ?

    If yes, then I have a solution for your problem.


    Thanks, Ali Yasir

    Thursday, October 25, 2012 10:18 PM
  • Hello Ali Yasir

        I have been away for little while.

        Regarding your question however,  I am now using Visual Studio 2010 Ultimate.

        I did try to use Visual Studio 2012 but the error message that I got was that my
    operating system is not new enough, which is strange because I am using
    "Windows 2008 Server". 

        But I can understand if VS2010 is looking for "Windows 2008 Server R2" because
    it has more capabilities.

        I also tried Microsoft Visual Web Developer Express and C# Express 2010 but they
    ddn't have the capabilities that I needed. 

        So my response to you is that I have not tried VS11 beta unless one of the above
    software downloads it without saying it did. 

        Since then I uninstalled Microsoft Visual Web Developer Express and C# Express 2010
    and Visual Studio 2012. 

        However, I did not uninstall anything from the registry, could there be something
    remaining in the registry and if not what do you think it is?

        Thank you
        Shabeaut

    Sunday, October 28, 2012 12:08 AM
  • Hi Shabeaut,

    I once faced this similar issue with VS11 and Yes its very much related to registry thing. Actually what happens is when Visual Studio 2010 and Visual Studio 11 Beta are installed side by side, the following error message occurs when a SharePoint form solution is debugged in Visual Studio 2010. Debugging continues for all the other SharePoint artifacts after the error message is dismissed, except for SharePoint Workflow, which cannot be debugged. The issue still exists after either Visual Studio 11 Beta or Visual Studio 2010 is uninstalled, and then debugging is performed in the remaining version of Visual Studio.

    To resolve this issue. I did the following changes in the registry.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\11.0\CLSID\{4FF9DEF4-8922-4D02-9379-3FFA64D1D639}]
    "InprocServer32"="C:\\Program Files (x86)\\Microsoft Visual Studio 10.0\\Common7\\Packages\\Debugger\\vsdebug.dll"
    "ThreadingModel"="Apartment"
    @="CLSID_SDMProgramProvider"

     

    If Visual Studio 11 Beta is uninstalled after it was installed side by side with Visual Studio 2010, then also add the following content to the .reg file:

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ControllerConduitTypeName"="Microsoft.Workflow.DebugEngine.ControllerConduit, Microsoft.Workflow.DebugController, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ControllerConduitTypeName"="Microsoft.Workflow.DebugEngine.ControllerConduit, Microsoft.Workflow.DebugController, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ExpressionEvaluationFrameTypeName"="Microsoft.Workflow.DebugEngine.ExpressionEvaluationFrame, Microsoft.Workflow.ExpressionEvaluation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ExpressionEvaluationFrameTypeName"="Microsoft.Workflow.DebugEngine.ExpressionEvaluationFrame, Microsoft.Workflow.ExpressionEvaluation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_CLASSES_ROOT\CLSID\{C511163B-37F1-45b2-826D-336F894B0143}\InprocServer32]
    "Assembly"="Microsoft.Workflow.DebugController, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_CLASSES_ROOT\CLSID\{C511163B-37F1-45b2-826D-336F894B0143}\InprocServer32\10.0.0.0]
    "Assembly"="Microsoft.Workflow.DebugController, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_CLASSES_ROOT\CLSID\{C511163B-37F1-45b2-826D-336F894B0143}]
    "ProgId"="Microsoft.Workflow.DebugEngine.ControllerConduit.10.0"

     

    If you plan to uninstall Visual Studio 2010, then before you do so, save the following assemblies so that you can restore them after uninstallation:

    C:\Program Files\Common Files\Microsoft Shared\WF\WDE.dll
    C:\Program Files\Common Files\Microsoft Shared\WF\amd64\WDE.dll
    C:\Program Files (x86)\Common Files\microsoft shared\WF\WDE.dll

    And then save the following into a .reg file to apply the change of your registry:

     

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ControllerConduitTypeName"="Microsoft.Workflow.DebugEngine.ControllerConduit, Microsoft.Workflow.DebugController, Version=11.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ControllerConduitTypeName"="Microsoft.Workflow.DebugEngine.ControllerConduit, Microsoft.Workflow.DebugController, Version=11.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ExpressionEvaluationFrameTypeName"="Microsoft.Workflow.DebugEngine.ExpressionEvaluationFrame, Microsoft.Workflow.ExpressionEvaluation, Version=11.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Net Framework Setup\NDP\v3.0\Setup\Windows Workflow Foundation\Debugger]
    "ExpressionEvaluationFrameTypeName"="Microsoft.Workflow.DebugEngine.ExpressionEvaluationFrame, Microsoft.Workflow.ExpressionEvaluation, Version=11.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    Let me know if it helps....


    Thanks, Ali Yasir

    • Proposed as answer by ManuelGB Sunday, April 14, 2013 12:54 AM
    Sunday, October 28, 2012 6:11 AM
  • Hello Ali Yasir

        I have not knowingly installed VS2011 beta.

        Assuming the other software that I did install
    could be the caused this problem,  I will follow you
    instructions.

        The only thing is you have to tell me what it is
    now and what to change it to.

        Thank you
        Shabeaut

    Sunday, October 28, 2012 9:50 PM
  • Hi Shabeaut,

    A "SharePoint Project" is a special project for SharePoint developing, it is not a web application, so there is no web.config.
    "Enable Debuggers" is disabled  by design.

    For the issue, "Attaching the ProteusDebugEngine debugger to process '[9164] w3wp.exe' on machine  <server name> failed. Invalid pointer" and the coming issue, it is generally caused by the w3wp.exe process is not ready finally.

    Generally, we use the following was to debug a solution:
    1. Right-click project, and then click Deploy to deploy the solution.
    2. Open the site manually
    3. Run Command Prompt(CMD), execute: cd /d "c:\windows\system32\inetsrv"
    4. List w3wp.exe processes: appcmd list wp, get the process id for the w3wp for the debugging site
    5. Go to Visual Studio, click menu "Debug" > "Attach to process..."
    6. Select the w3wp.exe that has the id we got from step 4. Please check "Show processes from all users" and "Show processes in all sessions"

    Thanks,
    Jinchun Chen


    Jinchun Chen
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff AT microsoft.com(Please replace AT with @)

    • Marked as answer by Qiao Wei Sunday, November 11, 2012 3:00 PM
    Monday, October 29, 2012 9:08 AM
  • In addition, I would suggest you updating VS to 2010 SP1:
    http://www.microsoft.com/en-us/download/details.aspx?id=23691

    Jinchun Chen
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff AT microsoft.com(Please replace AT with @)

    • Marked as answer by Qiao Wei Sunday, November 11, 2012 3:00 PM
    Monday, October 29, 2012 9:09 AM
  • Hello Jinchun Chen

        Thank you for responding.

         At this moment I can not implement your changes because
    here we have just experienced a natural disaster, specifically a "hurricane".

        As soon as I have done my part in the cleanup effort I wll resume my
    SharePoint and give you my results.

        Thank you
        Shabeaut

    Tuesday, October 30, 2012 11:24 PM
  • Hello,

    I have the same problem and the solution of AliYasir solved it.

    Thank you very much.

    Sunday, April 14, 2013 12:55 AM