none
VS 2015,C# Designer Process Crashes

    Question

  • New install of VS 2015 Community Edition Version 14.0.24720.00 Update 1, on a new Dell running Win 10 Pro, build 10586.

    I created new C# Windows Universal Blank App. Opened "MainPage.xaml", see loading Designer prompt, then an unhandled exception occurs on the designer.  Error message is at the end of post.

    No code has been added or changes made to the blank project.  The system is in Developer mode.

    Have tried repairing and reloading Visual Studio.  Followed multiple MSDN and Google reports of similar errors, but found nothing that resolves problem.

    Tried inputting a "Hello World" following this outline: https://msdn.microsoft.com/en-us/library/windows/apps/dn765018.aspx and the app compiles without error, then crashes calling the debugger, with a message: "Unable to activate Windows Store app".

    Any suggestions or ideas?

    Larry

    The following error message occurs:

    System.Runtime.Remoting.RemotingException
    [4548] Designer process terminated unexpectedly!
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.ProcessDomainFactory.ProcessIsolationDomain.Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IIsolationDomain.CreateInstance(String assemblyName, String assemblyCodeBase, String typeName)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.IsolationBoundary.Initialize()
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.IsolationBoundary.CreateInstance[T](Type type)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedObjectFactory.Initialize()
       at Microsoft.VisualStudio.DesignTools.DesignerHost.Services.VSIsolationService.CreateObjectFactory(IIsolationTarget isolationTarget, IObjectCatalog catalog)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolationService.CreateLease(IIsolationTarget isolationTarget)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.IsolatedDesignerService.CreateLease(IIsolationTarget isolationTarget, CancellationToken cancelToken, DesignerServiceEntry& entry, IServiceProvider serviceOverrides)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.IsolatedDesignerService.IsolatedDesignerView.CreateDesignerViewInfo(CancellationToken cancelToken)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedTaskScheduler.InvokeWithCulture[T](CultureInfo culture, Func`2 func, CancellationToken cancelToken)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedTaskScheduler.<>c__DisplayClass10_0`1.<StartTask>b__0()
       at System.Threading.Tasks.Task`1.InnerInvoke()
       at System.Threading.Tasks.Task.Execute()

    Tuesday, December 29, 2015 10:48 PM

All replies

  • Hi Inyoung,

    First, please check whether your project is stored on the path where Visual Studio installed.

    Then please make sure you have install the Windows 8.1 and Windows Phone 8/8.1 Tools and Windows 10 SDK. I also has the same problem because lack of these Tools and SDK. If not, please install the Windows 8.1 and Windows Phone 8/8.1 Tools from Control Panel -> Program and Features -> Visual Studio 2015 -> Change -> Modify and install the Windows 10 SDK from below link.

    https://dev.windows.com/en-us/downloads/windows-10-sdk

    Besides, please close all third part software when running Visual Studio 2015, such as antivirus. And make sure current user of Windows is administrator. If not, please change an other user to run Visual Studio as administrator.

    In addition, please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    Best Regards,
    Weiwei



    Wednesday, December 30, 2015 6:21 AM
    Moderator
  • Weivei,

    Did a  reinstall of VS 2015 community and verified that Windows 8.1 and Windows Phone 8/8.1 Tools and Windows 10 SDK tools were installed.  I have fixed the "Unable to activate Windows Store app" problem, but not the designer issue.

    The vscollect program did not give me a cab, but a zip.  Here is the link to the directory: 

    https://onedrive.live.com/redir?resid=2B2463B6172B0BB0!158324&authkey=!AKAgPv-eSTuSf4s&ithint=folder%2c

    Thanks for your help.

    Larry

    Thursday, December 31, 2015 6:55 PM
  • Hi Inyoung,

    According to the installation log, your Visual Studio installed correctly.

    Please try deleting your shadow cache at C:\Users\{user}\AppData\Local\Microsoft\VisualStudio\12.0\Designer\ShadowCache.

    And please try modify the Solution platform from Any CPU to x86 or x64  to check whether it could fix this problem.

    If it still doesn't work, I suggest you post this problem to Visual Studio Connect to feedback this problem and share the link here. It can let other communities who has the same problem to vote your feedback.

    https://connect.microsoft.com/visualstudio

    Best Regards,
    Weiwei

    Friday, January 01, 2016 5:24 AM
    Moderator