none
EF 4.3 cause plattform not supported exception in xp RRS feed

  • Question

  • Hello,
    I use  net 4.0 und vs 2010 and Entity Framework 4.3 (installed with nugets packages administrator)

    I'll use the EF4.x DbContext generator to give me the Poco classes and generate the DbContext to

    The application runs without problems on my computer (Windows 7).
    I have tested the Apllikation on a xp. there is an error in the first LINQ query
    NotSupportedException in System.Core
    Additional info: The specified Krypthografiealgorithmus is not supported on this platform

    I use myself in my code but no encryption.

    the call stack shows the last call: System.Security.Crypthographi.SHA256CryptoServiceProvider and CapiNative.AcquireCsp...

    EF is used in c# dll and this dll is called from C-program over a wrapper

    I have in C-Program in VS in debug-> expression den system.Notsupported plattform on

    anyone know how I can fix this?

    Monday, July 15, 2013 2:02 PM