none
"Run INFTest against a single INF" fails - cannot find inf RRS feed

  • Question

  • We are trying to get a driver signed, thus running the driver tests in DTM 1.6 (with all the latest filters applied as of Dec '12).
    All tests pass except for Run INFTest against a single INF - this fails.
    The full log follows below.
    When I run chkinf against the .inf file - I get some warnings but no errors. It passes.
    When I run inftest against the .inf file, it passes.
    However when run in DTM, this fails.

    The issue I see is that DTM looks for the .inf file as installed on the test machine and passes that inf file (found in c:\windows\inf) to the test. In this case however, it fails to find the inf file (although I can see it there in the inf directory) and so chkinf fails as no .inf file is specified. I determine this based on the commandline option for chkinf: -l C:\Windows\inf\  <the expected file is blank, all that is passed in is a directory, no inffile).

    I've reloaded the driver and recreated a submission using the same driver. I've tried a few other various things, all to no avail. I dont understand why DTMs DeviceConsole cannot find the inf file.

    Questions:
    1. what could possibly be wrong and how do I fix it?
    2. how does DTM look for the driver on the test machine (perhaps I can then do some digging to find out why DTM is not finding it). This is all under the covers, so it is extremely difficult to troubleshoot issues.

    My issue is with a NDIS filter driver on Windows Server 2008 R2 x64.

    ==

    Complete Test Log
    Runtime 1/11/2013 8:42:24.359 AM _ 
    Runtime Index:   3493357417
    Machine:   DTM-R2-ACGW
    Process Name:   C:\WLK\JobsWorkingDir\Tasks\WTTJobRunBECCEA6B-F17A-47A0-9C2A-C1B08A13422B\inftest.exe
    Process ID:   1432
    Thread ID:   2608
    Context _  _ 
    Context Index:   384048256
    Current:   WTTLOG
    Parent:   ROOT
    Computer 1/11/2013 8:42:24.359 AM _ 
    OS:   Windows Server 2008 R2 Enterprise
    Version:   6.1.7601.1130 x86 
    Language:   English (US) (REDMOND)
    Build String:   win7sp1_rtm-101119-1850
    Context _  _ 
    Context Index:   2439827631
    Current:   FABBDC82-BACD-4D23-A2D7-30219463EB0E
    Parent:   WTTLOG
    Start Test 1/11/2013 8:42:24.359 AM Inftest
    Error 1/11/2013 8:42:24.359 AM Could not find user specified INF files. Bailing out ...
    File:   d:\6229\sdktools\ddk\tools\inftest\wttlog.cpp Line: 272
    Error Type:   WIN32
    Error Code:   0x6
    Error Text:   The handle is invalid.
    Assertion 1/11/2013 8:42:24.359 AM Could not expand user supplied lists of infs into individual filenames.
    : See inftestdbg.log for more information
    File:   chkinf.bat Line: 1
    End Test 1/11/2013 8:42:24.359 AM Inftest
    Result:   Fail
    Repro:   "C:\WLK\JobsWorkingDir\Tasks\WTTJobRunBECCEA6B-F17A-47A0-9C2A-C1B08A13422B\i386\inftest.exe" -wdk -p C:\WLK\JobsWorkingDir\Tasks\WTTJobRunBECCEA6B-F17A-47A0-9C2A-C1B08A13422B -f /LG -l C:\Windows\inf\
    Pass/Fail Result Rollup Counts 1/11/2013 8:42:24.359 AM _ 
    Total:   1
    Passed:   0
    Failed:   1
    Blocked:   0
    Warned:   0
    Skipped:   0

    Friday, January 11, 2013 2:21 PM

All replies

  • I got in touch with and heard back from winqual. This is their response to me:

    "You can use Errata 2111 for this failure it is known issue."

    Not sure if it will be applicable, but something to try. Hopefully that will help others out when they run into this.

    • Proposed as answer by certeonEng Monday, January 14, 2013 6:08 PM
    Monday, January 14, 2013 6:08 PM