locked
assets in blend RRS feed

  • Question

  •    Hoping someone here may be able to help.  I have a significant number of Silverlight assets in VS 2008 with sp1 and SL3, than I do in Blend 3 SDk 3 etc.  I purchased Blend about 2 mos. ago,  and downloaded SDK3.  I tried a couple of times to download SL 3 toolkit again,  but it doesn't update blend.  I find it especially strange because,  I can watch the download scanning through the files for VS2008 and Visual Web developer and C# express,  which are also on my computer, but it never scans through the Blend files.  It doesn't seem to recognize its existence on the computer.  I find myself going to VS to pull an expander or a wrap panel into the project and returning to Blend.  They then function fine once I have them.  Is there a way that I can bring them into Blend as a permanent addition?
    Thursday, February 25, 2010 2:09 AM

All replies

  • Hi,
         You should check if you have following reg ket setup on your machine, if not try adding it and Blend will then load all the control from Silverlight Toolkit in the Asset Tool.

    Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Expression\Blend\3.0\Toolbox\Silverlight\v3.0\SilverlightToolkit0910
    Value (On my machine): "C:\Program Files\Microsoft SDKs\Silverlight\v3.0\Toolkit\Oct09\Bin\"

    You can similarly add reg key for Toolkit Themes
    Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Expression\Blend\3.0\Toolbox\Silverlight\v3.0\SilverlightToolkitThemes0910
    Value (On my machine): "C:\Program Files\Microsoft SDKs\Silverlight\v3.0\Toolkit\Oct09\Themes\"


    Note: Value might change based on version of Silverlight 3 Toolkit installed on your machine

    Hope this helps.

    Thanks,
    Navit Saxena
    • Proposed as answer by navits - MSFT Thursday, February 25, 2010 9:23 PM
    Thursday, February 25, 2010 9:23 PM
  •     The key is not there.  I did what I thought was going to correctly add the key, and got a message saying it was complete, but it hasn't worked.  I'm apparently not adding the key correctly.  Neither the key nor the assets were there afterwards.
    Friday, February 26, 2010 4:02 AM
  • Hi,
         You can try this and see if it works:

    1. Uninstall Blend 3 and Blend 3 SDK
    2. Uninstall Silverlight 3 Toolkit
    3. Install Blend 3 again
    4. Install Silverlight 3 Toolkit

    To best of my knowledge, installation of Silverlight 3 Toolkit should add the required reg key to enable Blend to load required assemblies.

    Thanks,
    Navit Saxena
    Friday, February 26, 2010 7:29 AM
  •      Thanks.  I was hoping to avoid that, but there doesn't seem to be another solution.  I have tried many.  Thanks alot for your help.
    Friday, February 26, 2010 1:21 PM
  • Hi,
         Please do let us know if the above solution works for you. We will also try to investigate this issue in detail with Silverlight Toolkit team.

    Thanks,
    Navit Saxena

    Friday, February 26, 2010 6:43 PM
  •      I un-installed blend, and blend sdk 3 and the oct and nov SL updates, re-installed everything:  still have only the assets avialable by aug of '09.  Newer updates are not updating blend.  I really appreciate your help. Thanks.

    It's about 6 hours later. Just had a problem that I hadn't yet encountered.  As I've said earlier,  if I'm working on something that needs an asset that I have in VS2008, but not in Blend,  I have been pulling it in in VS and moving back later to Blend.  I was working on something that I was using a Grid Splitter on.  After including it while I was in VS2008, and then doing some additional work in VS,  Blend wouldn't update with the new work.  I saved everything on both sides, and closed VS.  When I re-opened it everything was gone from both.  I have noticed that when I include one asset from VS to a project,  the whole VS SL 3 library becomes visible in Blend, including all the most recent updates.   But, losing the project that I was working on has me frustrated.  Before it was just a matter of using a work around.  Hoping that you can advise me.  Thank you again.
    Saturday, February 27, 2010 11:26 PM
  • Finally!!! Got the missing assets into Blend. I revisited the registry and tried the key and new value again with success. The theme addition, which I also tried, hasn't worked yet. But, I'll give it another try later, I'm sure that it was something that I missed. Once again thanks for all of your help.
    Sunday, February 28, 2010 11:52 AM
  •      Well, bad news.  They only showed up for that one session.  They're not present in any new project that I open.  I can rember at some point, before re-installing everything, finding some configuration window that was checked: Never, for updating Silverlight.  I changed it at that time, but can't remember where it was.  I'm wondering if, after re-installation, there is something prohibting an update.  I have tried a couple of variations on changing the registry keys and values, which seemed like it should do it.  But, each time the same result: no asset update.  If you have any ideas, I'd really appreciate hearing them.  Thanks again.
    Sunday, February 28, 2010 8:29 PM