none
Sqlite not in list of Visual Studio 2013 data source options

    Question

  • Hi,

    My requirement is to generate "edmx" file from ".sqlite".

    My PC environment is Visual Studio 2013 with Windows 7 64-bit OS.

    I have intalled "sqlite-netFx451-setup-bundle-x86-2013-1.0.104.0.exe" and "sqlite-netFx451-setup-bundle-x86-2013-1.0.104.0.exe". But "Sqlite" option is not displaying in Data Source option as shown below pics.

    Here I referred below link:
    http://system.data.sqlite.org/index.html/doc/trunk/www/downloads.wiki
    http://stackoverflow.com/questions/10215488/sqlite-not-in-list-of-visual-studio-data-source-options


    Could you please help to resolve the issue.

    Note:
    I am able to generate sdmx file in VS 2010 with "SQLite-1.0.66.0-setup.exe" software.

    Thanks in advance.

    Hari

    Friday, April 7, 2017 4:10 PM

All replies

  • Have you tried 64 bit version - sqlite-netFx451-setup-bundle-x64-2013-1.0.104.0.exe &  sqlite-netFx451-setup-x64-2013-1.0.104.0.exe available in following link

    http://system.data.sqlite.org/index.html/doc/trunk/www/downloads.wiki


    Gaurav Khanna | Microsoft MVP | Microsoft Community Contributor

    Friday, April 7, 2017 6:11 PM
  • Hello,

    I have not tried using this provider but saw a comment indicating for the install as follows

    You must check the option "design-time components for Visual Studio 2015" in the installer. 

    Thinking it would be the same for VS2010.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    Friday, April 7, 2017 7:13 PM
    Moderator
  • I would say there is a problem with your install. Did you do a Full install? Did you select the check box for the Visual Studio 2013 design components when installing? Did you run the install with sufficient privileges (or as Administrator). I don't have 2013 installed but it works for me under 2010 and 2015.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Friday, April 7, 2017 8:35 PM
  • Thanks for the suggestion.

    I have tried by installing both software.

    But still "Sqlite" option is not displaying in Data Source.

    During installation time I did not find an option "design-time components for Visual Studio 2013".

    Attached screenshot for a reference.

    sqlite-netFx451-setup-x64-2013-1.0.104.0 installation wizard pic:

    sqlite-netFx451-setup-bundle-x64-2013-1.0.104.0 installation pic:

    But, while installing "sqlite-netFx451-setup-bundle-x86-2013-1.0.104.0.exe" software, "design-time components for Visual Studio 2013" option is displaying. But no use.

    Regards,

    Hari


    • Edited by GHBHAT Saturday, April 8, 2017 5:10 PM
    Saturday, April 8, 2017 5:09 PM
  • Visual Studio is 32-bit so the 64-bit version would not have the design components. You need the 32-bit version:

    Setup for 32-bit Windows (.NET Framework 4.5.1)


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Saturday, April 8, 2017 7:36 PM
  • Hi,

    Finally got a solution by doing overnight experiment.

    Installed 32 bit sqlite setup on top of 64 bit sqlite setup.

    I did below steps:

    1. Installed sqlite-netFx451-setup-bundle-x64-2013-1.0.105.0.exe
    2. Installed sqlite-netFx451-setup-bundle-x86-2013-1.0.105.0.exe
    3. Open NuGet Console in VS2013:
        PM> Install-Package EntityFramework
        PM> Install-Package System.Data.SQLite -Version 1.0.105.0

    Do not know whether this is correct process or not. But it is working fine.

    Hope it will help someone.

    Regards,

    Hari.

    Tuesday, April 11, 2017 12:13 PM
  • Hi GHBHAT,

    Please Mark as answer or Vote as helpful post to the appropriate answer so that it will help other members to find solution if they faces similar issue.

    Your understanding and cooperation will be grateful.

    Thanks,
    Sabah Shariq

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, April 13, 2017 8:42 AM
    Moderator