locked
Remoted iOS Simulator black screen RRS feed

  • Question

  • User234188 posted

    Was very excited for the remoted iOS Simulator being available to all, but I'm having issues getting it to load anything.

    My Mac is an iMac 2013 running Sierra and XCode 9.1 (latest from Apple app store). The simulator works great on this machine, and I can use the Simulator on the Mac while working in VS2017 15.5 on my PC (Windows 10 with the Creator's update from this spring)

    The remoted iOS simulator window launches but the window is just black. Doesn't matter what device I pick from the list (iPhone SE, iPhone 7, iPhone 8+, iPhone X), the simulator window loads that device and just sits there. All the controls along the top are grayed out/disabled, too.

    If I uncheck the box to use the remote simulator, the simulator loads on the Mac and my app starts in debug mode. So the only difference is whether it's remoted or not.

    Here's the latest log from my PC's C:\Users\\AppData\Local\Xamarin\Logs\Xamarin.Simulator - any suggestions are welcome.

    Startup: arguments: --device=191BCE49-CCE1-4839-A5B0-57339F7D03A6 --launchsim=//Users/ben/Library/Caches/Xamarin/mtbs/builds/myApp.iOS/8a25c1926c906d3fadda35cb8d8fd4c7/bin/iPhoneSimulator/Debug/myApp.iOS.app -argument=-monodevelop-port -argument=55752 -setenv=__XAMARIN_DEBUG_PORT__=55752 --sdkroot=/Applications/Xcode.app -h=iMac -ssh=benfunk --launched-by=devenv-15.0 version: 1.2.0.32 (58127509f49b2041fdd4926c8d915f1c5400413e) Connection state changed: State: Connecting SSH Connect: target: iMac:4231 Using SSH pass phrase SSH connected Connection state changed: State: Connected Connection state changed: State: CheckingServer Connection state changed: State: Connecting Connection state changed: State: CheckingServer Connection state changed: State: Connected Start device request: Current State: Unknown UUID: 191BCE49-CCE1-4839-A5B0-57339F7D03A6 Name: iPhone 8 Platform: iOS Version: 11.1 Device state changed: UUID: 191BCE49-CCE1-4839-A5B0-57339F7D03A6 State: Starting Device state changed: UUID: 191BCE49-CCE1-4839-A5B0-57339F7D03A6 State: Unknown Device state changed: UUID: 191BCE49-CCE1-4839-A5B0-57339F7D03A6 State: Starting Device state changed: UUID: 191BCE49-CCE1-4839-A5B0-57339F7D03A6 State: Unknown SizeForScreen: Monitor: 0,0,1920,1040 Scale: 1,1 Source: 750,1334 extraHeight: 84

    Tuesday, December 5, 2017 5:33 PM

All replies

  • User104869 posted

    +1

    Monday, December 11, 2017 9:10 AM
  • User209348 posted

    The Windows iOS Simulator has not worked for many months... 6+ months... So what you're seeing is normal....

    Yes, wasted installing Enterprise to learn this a long time ago...

    Tuesday, December 12, 2017 3:26 AM
  • User74 posted

    @GVx said: The Windows iOS Simulator has not worked for many months... 6+ months... So what you're seeing is normal....

    Yes, wasted installing Enterprise to learn this a long time ago...

    That might be your experience, it certainly isn't mine. The remote iOS simulator works very well for us. We just needed to use it exactly as described, be logged in on the Mac and as the same user logged into Windows.

    Tuesday, December 12, 2017 8:00 AM
  • User234188 posted

    I've figured out exactly where it's getting stuck.

    I have to open the Simulator on my Mac and the controls are now available. If I set both Visual Studio and the Simulator to the same hardware, then when I run the app the Simulator on the Mac shows the app. The remoted simulator is still black-screened. But if I "feel around" find click where a button should be, I can see the app on the Mac react. I can use the controls at the top to rotate the simulator or take screenshots on my Mac. And when I close the simulator on my PC, the device disappears on my Mac, as well.

    So the problem, for me, anyway, is that the Simulator isn't receiving video from the Mac. Or if it is, it's not displaying it. It's amusing but not usable.

    Tuesday, December 12, 2017 7:38 PM
  • User284020 posted

    I`m having the same issue. :(

    Wednesday, January 10, 2018 5:30 AM
  • User126134 posted

    I have had the same issue, black screen in the remote simulator. I've solved it by adding a rule in the Windows firewall. So try to check your firewall.

    Tuesday, October 2, 2018 8:02 AM
  • User378288 posted

    Hi,

    I had the same issue too , after an update everything works fine

    Wednesday, October 3, 2018 11:24 AM
  • User136377 posted

    Same issue here. I do find that it will work with certain simulators. It works with iPhone 6 and 6 plus, but not iPhone 11 or iPad 12.9 inch 3rd gen, I haven't tried any others yet. Could it have something to do with screen size and the number of pixels?

    As others have noted, you can see the simulator running on the mac but the remoted screen is black. You can carefully click on the remoted screen and see the response on the mac if you click the right spot.

    Thursday, September 26, 2019 5:13 PM
  • User259932 posted

    @Jean-LouisPORCILE What program did you let through your firewall to make this work?

    Wednesday, October 2, 2019 3:46 PM
  • User126134 posted

    @"RobertRoss.0951"

    Rule Name: Xamarin Mac Agent

    Enabled: Yes Direction: Out Profiles: Domain,Private Grouping: LocalIP: Any RemoteIP: Any Protocol: TCP LocalPort: Any RemotePort: 22 Edge traversal: No Action: Allow

    Rule Name: Xamarin Mac Agent

    Enabled: Yes Direction: In Profiles: Domain,Private Grouping: LocalIP: Any RemoteIP: Any Protocol: TCP LocalPort: 22 RemotePort: Any Edge traversal: No Action: Allow

    Wednesday, October 2, 2019 3:59 PM
  • User126134 posted

    @"RobertRoss.0951"

    I found another case that cause the black screen. It is when several user sessions are opened on the Mac.

    Wednesday, October 2, 2019 4:01 PM
  • User259932 posted

    Thank you I will give those a shot

    Wednesday, October 2, 2019 4:04 PM
  • User387241 posted

    It was the firewall for me too. Just turned it off temporarily, all fine now.

    Monday, December 30, 2019 9:40 PM
  • User392645 posted

    Great information thanks for share it.

    Friday, February 7, 2020 10:10 AM