locked
Deployment of ADF pipeline failing because ADF is looking for URI with HTTPs enabled RRS feed

  • Question

  • Hi everyone,

    I'm attempting to build a custom activity for ADF as detailed in https://azure.microsoft.com/en-us/documentation/articles/data-factory-use-custom-activities/#updating-a-custom-activity

    However, I'm getting the following exception when I attempt to deploy the pipeline:

    "https://XXXXXX.blob.core.windows.net/customactivitycontainer/MyDotNetActivity.zip was not found"

    I believe this issue is because the URI for the blob in my container is listed as (note it's not HTTPS): "http://XXXXX.blob.core.windows.net/customactvitycontainer/MyDotNetActivity.zip"

    Basically the pipeline is looking for my URI with HTTPS but the actual URI in my container is listed down as mere HTTP. 

    I haven't encountered this issue although to be fair I have only been working with Azure ADF for a week :). Is there a way to turn off the HTTPS?

    I would really appreciate any help with this issue. Thanks.

    Regards

    Alex


    Wednesday, September 23, 2015 2:54 PM

Answers

  • This issue has now been resolved.
    • Marked as answer by AlexGomez11 Wednesday, October 7, 2015 1:15 PM
    Thursday, September 24, 2015 9:53 AM

All replies

  • This issue has now been resolved.
    • Marked as answer by AlexGomez11 Wednesday, October 7, 2015 1:15 PM
    Thursday, September 24, 2015 9:53 AM
  • Please check the path to your .zip package.

    Azure storage supports access via HTTP and HTTPS, and ADF always uses secure connections.

    Sunday, March 27, 2016 6:15 PM