locked
Service Bus Queue is not available now ! RRS feed

  • Question

  • The Service Bus Queue which had been running without any error, occurs the following error.

    --------------------------------------
    An unhandled exception of type 'System.UnauthorizedAccessException' occurred in Microsoft.ServiceBus.dll

    Additional information: The remote server returned an error: (401) does not allow claim is empty TrackingId:. F1ae8661-2b46-433e-9621-c7b91c5927e3_G7, SystemTracker: digipub.servicebus.windows.net: DigipubOrder_Session, Timestamp: 7/20/2016 2:18:55 AM
     --------------------------------------

    By debugging, I found that the error ocurrs at "namespaceManager.QueueExists (queueName)" in the following C# source.  I checked again this "ConnectionString" by the Azure management portal.  It was the same string.


    - Is there an expiration date of ConnectionString?

    - In that case, how can we update it?

    - Or is there any possibility of adverse effect of the current Service Bus Queue version-up? In that case, please tell us how can we solute the problem.

    - In such a case as  "destructive" version-up giving a direct impact on the running program,  where will the pre-announcement be done?

    Any help and hint is most welcome.
    Thank you in advance.
     

    --------------------------------------
    (C# source for PowerShell library)

            public QueueClient InitializeParamWithSession(string connectionString, string queueName, bool useSession, bool? deleteAfterReceipt)
             {
                 QueueDescription queueDescription = new QueueDescription(queueName)
                 {
                     RequiresSession = useSession
                 };

                var namespaceManager = NamespaceManager.CreateFromConnectionString(connectionString);

                if (!namespaceManager.QueueExists(queueName))
                 {
                     namespaceManager.CreateQueue(queueDescription);
                 }
                 var GQueueClient = CreateQueueClient(connectionString, queueName, deleteAfterReceipt);
                 return GQueueClient;
             }

            public QueueClient CreateQueueClient(string connectionString,string queueName, bool? deleteAfterReceipt)
             {
                 ReceiveMode receiveMode;
                 if (deleteAfterReceipt != null)
                 {
                     if (deleteAfterReceipt == true)
                     {
                         receiveMode = ReceiveMode.ReceiveAndDelete;
                     }
                     else
                     {
                         receiveMode = ReceiveMode.PeekLock;
                     }
                     return MessagingFactory.CreateFromConnectionString(connectionString).CreateQueueClient(queueName, receiveMode);

                }
                 else
                 {
                     return MessagingFactory.CreateFromConnectionString(connectionString).CreateQueueClient(queueName);

                }
             }
     --------------------------------------


    • Edited by SOhtsu Friday, July 22, 2016 1:58 AM
    • Moved by Swikruti Bose Friday, July 22, 2016 12:45 PM Related to Service Bus
    Friday, July 22, 2016 1:57 AM

Answers

  • I do not know "why", but our programs are working now.
    Thank you so much.
    If there will be destructive updates, please notify us "in advance".
    • Marked as answer by SOhtsu Wednesday, July 27, 2016 11:15 AM
    Wednesday, July 27, 2016 11:13 AM

All replies

  • Greetings,

    Sorry for inconvenience caused.

    How about the issue now are you still facing the same issue? If yes please write back to about the status, we are happy to assist you with more information.

    As we had an outage yesterday because of service impact due to the sql incident, that is up and now working fine.

    Please let us know the status.

    Regards,

    Friday, July 22, 2016 5:01 PM
  • Thank you for your prompt reply.

    Our current situation is not changed, the same error occurs.

    I think that recent version-ups cause it.

    In earlier, if Namespace's "RootManageSharedAccessKey" was set, we could get the queue name list. Now is it necessary that SAS policy be set to each queue, depending on the version-up?

    For example, in the Azure Classic Management Portal,

    - Select "Service Bus" in the left menu.
    - Select a target name space.
    - Click the "technical information" link on the bottom.
    - Target connection string will be displayed.

    Then

    - Select the "Queue" in the top menu.
    - Click "Display connection string" in the right menu.
    - "No SAS policy configured for this entity" will be displayed.

    I think that it might be the cause of the error.

    Please tell us how to cope with it.

    Any help or hint is most welcome.
    Thank you.


    • Edited by SOhtsu Saturday, July 23, 2016 2:07 AM
    Saturday, July 23, 2016 2:04 AM
  • Is the rest of SB calls working fine? You said you bumped up the version. Can you please tell me what client version you are currently on and you were on prior to change? I would like to see if I can repro this issue locally.

    Monday, July 25, 2016 6:48 PM
  • I do not know "why", but our programs are working now.
    Thank you so much.
    If there will be destructive updates, please notify us "in advance".
    • Marked as answer by SOhtsu Wednesday, July 27, 2016 11:15 AM
    Wednesday, July 27, 2016 11:13 AM
  • Hi

    I got same error when I click my Queue URL in Azure. Could you please help?

    <Error>

    <Code>401</Code>

    <Detail>claim is empty. TrackingId:444794bd-192c-4cb9-a5ed-37c7d5126255_G1, SystemTracker:datasrv.servicebus.windows.net:queuetest1, Timestamp:7/20/2017 5:49:43 PM</Detail>

    </Error>



    • Edited by Jiahui Sun Thursday, July 20, 2017 6:00 PM
    Thursday, July 20, 2017 5:59 PM
  • Hi Jiahui,

    Were you able to access the Queue URL as I am aslo geeting the same error.

    Could you please help me on this.

    Monday, January 22, 2018 11:36 AM