locked
Visual Studio 2008 lost hard drive Oracle install RRS feed

  • Question

  • User-373571878 posted

    Hello,

    The hard drive went on my laptop. I am in the process of reinstalling the pieces I need to run my apps(programs).
    I used to have Oracle ODAC 11g installed.

    When I went looking for it again I see there are new versions of it available. One particular says it has tools for Visual Studio users, but mentions Visual Studio 2012.  Can I load this version if I am using VS 2008 or should I look for an older version to download?

    Thanks

    Thursday, October 25, 2012 9:46 AM

Answers

  • User269602965 posted

    Oracle has a beta MANAGED ODP.NET driver which may eliminate all these versioning concerns.  Currently the beta is missing some functionality of the final version, and the configuration is different, code calls appear the same except for namespace. 

    The last time I was at there driver site, the older versions were still there.  If you do not need the VS Tools, and I do not use them anyway, you can OPT out and just install the Client with the ODP.NET drivers.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 25, 2012 10:30 AM
  • User-373571878 posted

    Oracle ODAC does include an Oracle Express Client, however some choose to download the Oracle 11g client as well.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, November 9, 2012 11:27 AM

All replies

  • User269602965 posted

    Oracle has a beta MANAGED ODP.NET driver which may eliminate all these versioning concerns.  Currently the beta is missing some functionality of the final version, and the configuration is different, code calls appear the same except for namespace. 

    The last time I was at there driver site, the older versions were still there.  If you do not need the VS Tools, and I do not use them anyway, you can OPT out and just install the Client with the ODP.NET drivers.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 25, 2012 10:30 AM
  • User-373571878 posted

    Thanks Lannie,

    the error I get upon compile is:

    Could not load file or assembly 'Oracle.DataAccess, Version=2.111.6.20, Culture=neutral, PublicKeyToken=89b483f429c47342'

    I do still have the folders that were installed on the original hard drive, (they were copied back by a tech person from the old to the new hard drive),  But I get that error when I try to compile. I think because the install needs to take place again to setup proper registering etc that happens upon install.

    I am just not sure what version of Oracle ODAC 11g 11.2.... to use, 2.111.620 as stated in error (I dont see it listed) or should i use a newer one? 

    Plus is the Oracle ODAC 11g a client or just a data reader?

    I'm a little confused about that too.

    Thanks 

    Thursday, October 25, 2012 2:56 PM
  • User-373571878 posted

    Oracle ODAC does include an Oracle Express Client, however some choose to download the Oracle 11g client as well.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, November 9, 2012 11:27 AM