none
Biztalk 2010 - json to xml conversion pipeline using HTTP adapter RRS feed

  • Question

  • Hi

    i have developed a biztalk 2010 application using http adapter.

    I am getting xml output using this.Also i added xmltojson pipeline in send pipeline of receiving location and i could successfully able to convert the xml output to json format

    But when i added json to xml pipeline as receive pipeline in receive location iam getting error

    The adapter failed to transmit message going to send port 

    This is the json input i am giving

    {
       "HJH": "cccc",
       "OIOI": "vvvvv"
    }


    • Edited by Suja Balan Wednesday, October 26, 2016 2:02 PM
    Tuesday, July 19, 2016 8:08 AM

Answers

All replies

  • Hi

    How are you creating the Oracle XML message - is there a map? Open the suspended message in Admin Console and share how it looks like.

    The error is this-

    Unexpected start node "___" with namespace "" found.

    There is no namespace in the message you are sending to the SendPort. Basically, the XML message expected by the WCF Oracle adapter is not getting created correctly.

    Can you check/test if the AddNamespace pipeline component is adding the namespace to the XML message in pipeline?


    Thanks Arindam



    Tuesday, July 19, 2016 8:12 AM
    Moderator
  • Sorry, I don't quite follow - what is the error?

    Thanks Arindam

    Tuesday, July 19, 2016 11:11 AM
    Moderator
  • Very important!  You must not use the HTTP Adapter.

    The HTTP Adapter has been deprecated.  The WCF based Adapters are the current solution.

    Tuesday, July 19, 2016 12:56 PM
    Moderator
  • Was this entire setup with the same components/pipeline configuration working fine with the FILE adapter earlier?

    Thanks Arindam

    Tuesday, July 19, 2016 1:03 PM
    Moderator