locked
Development tools are horribly broken

    General discussion

  • Seriously, for several years of WPF&Silverlight development I've never had a worse experience, what's up, MS?

    I'm using Windows 8 RTM and VS2012 Pro. 

    XDesproc takes ages to start. I've tried switching to x86 build target - nothing changed. It hangs for > 3 seconds on almost every code change, sometimes it crashes on itself, sometimes it brings my VS and Blend with it. It doesn't update user controls even after rebuild, but I managed to "fix" this by moving all user controls to top namespace. Blend doesnt update code changed in VS, though "Edit Externally" shows updated code. Sometimes after changes in VS, Blend's design "desyncs" with code, and when I click on elements - random parts of code get selected, and nothing works till Blend restart. Today I've spent an hour trying to find out why intellisense in VS locally stopped working. The problem was in line "Frame.Navigate(typeof(MainPage))", "typeof(MainPage)" causing all intellisense in block above it to stop working. 

    It's impossible to work like this, funny thing, I can't even post here with my main account, cause I get "too many redirects" error, when I'm logged in with it.

     

    Thursday, September 13, 2012 8:05 PM

All replies

  • Would love to understand these issues better. Could you please get in touch with me at unnir at Microsoft dot com so I can get more details and try to reproduce some of these on our end?

    Unni Ravindranathan, Program Manager, Microsoft Expression This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, September 15, 2012 6:04 PM