locked
Java Script RRS feed

  • Question

  • I discovered Windows SharePoint Services 3.0 (WSS) does not support Java Script. How can I remove it from the WSS script? Do I have to install FrontPage on the same server? The SharePoint site is flashing as a clock and I can not get in to the 'Site Actions' to edit the site. Can sSome one Please help! 
    Wednesday, August 13, 2008 1:56 PM

Answers

  • Sounds like you have disabled JavaScript in your browser.
    Try to add your site to the trusted sites in the IE and enable JavaScript. In IE Tools > Internet Options > Security > Custom level.

    Regards
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:33 PM
    Wednesday, August 13, 2008 2:52 PM
  •  I can't get you where I thought I could from there.

    Go to the page you need to remove the web part from and alter the URL ...

    place ' ?contents=1' at the end.  This will bring up the Web Part Maintenace Page.


    http://www.shannonbray.com/2008/08/failed-web-part.html


    Shannon Bray - MCT, MCPD, MCTS, MCITP
    Wednesday, August 13, 2008 7:34 PM
  • Seems like the Content Editor web part has problem, just try deleting that web part.

    Append ?Contents=1 at the end of url. Example http://domain/sites/site/default.aspx becomes http://domain/sites/site/default.aspx?contents=1 .. it will give youa list of web parts used on that page. Just select the content editor one & delete it.

    I hope it helps.
    Thanks, Arpit
    Wednesday, August 13, 2008 7:34 PM
  • This did not work, is there something different that I can do?
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:34 PM
    Wednesday, August 13, 2008 5:59 PM
  •  

    The SharePoint site is flashing as a clock and I cannot get in to the 'Site Actions' to edit the site.

     

    Here is how the clock was added to the site. I have full admin rights to all the SharePoint sites.

    To insert the clock we used the  following:

    1. Clicked on 'Site Actions' tab

    2. Opened 'Edit Page'

    3. Clicked on 'Add a Web Part'

    4. Clicked on 'Content Editor Web Part'

    5. Opened 'Source Editor' and inserted the Java code just above the Web/Page Maintainer Contact information.

    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:34 PM
    Wednesday, August 13, 2008 6:20 PM
  •  

     

    The problem I have is this:

    1.       We are using WSS as our Intranet and have different departments with sites.

    2.       The site I am having the ‘clock’ problem is one of 7 sub-sites under a Department Chief.

    3.       There are 7 sub-sites (sub-departments) under the Department Chief.

    4.       Do I start at the Department Chief site?

    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:35 PM
    Wednesday, August 13, 2008 6:36 PM
  • I made it to the site setting page, now where do I go?
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:35 PM
    Wednesday, August 13, 2008 7:17 PM
  • It worked and thank you very much for your help. I made some step by step 'Screen Shots' for my SharePoint note book.
    Thanks again.
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:36 PM
    Wednesday, August 13, 2008 8:16 PM

All replies

  • Sounds like you have disabled JavaScript in your browser.
    Try to add your site to the trusted sites in the IE and enable JavaScript. In IE Tools > Internet Options > Security > Custom level.

    Regards
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:33 PM
    Wednesday, August 13, 2008 2:52 PM
  • This did not work, is there something different that I can do?
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:34 PM
    Wednesday, August 13, 2008 5:59 PM
  • Can you please explain in detail what is happening.
    Are there any errors in event log?
    What IE version are you using?

    Regards
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Wednesday, August 13, 2008 6:07 PM
  • WSS actually has java script that it loads.  It is possible this is being blocked.

     Are you using IE or another browser?

    Do you see the 'Site Actions' button and it is just not responding?

    Do you have a custom java script control on your page?  This could be messing up the core.js script that WSS uses.
    Shannon Bray - MCT, MCPD, MCTS, MCITP
    Wednesday, August 13, 2008 6:08 PM
  •  

    The SharePoint site is flashing as a clock and I cannot get in to the 'Site Actions' to edit the site.

     

    Here is how the clock was added to the site. I have full admin rights to all the SharePoint sites.

    To insert the clock we used the  following:

    1. Clicked on 'Site Actions' tab

    2. Opened 'Edit Page'

    3. Clicked on 'Add a Web Part'

    4. Clicked on 'Content Editor Web Part'

    5. Opened 'Source Editor' and inserted the Java code just above the Web/Page Maintainer Contact information.

    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:34 PM
    Wednesday, August 13, 2008 6:20 PM
  •  It sounds like your clock is the problem.

    You can bypass your broken button by modifying the URL ... go to the home page and then paste in '/_layouts/settings.aspx'.

    I would remove that clock and see if everything goes back to normal.


    Shannon Bray - MCT, MCPD, MCTS, MCITP
    Wednesday, August 13, 2008 6:24 PM
  •  

     

    The problem I have is this:

    1.       We are using WSS as our Intranet and have different departments with sites.

    2.       The site I am having the ‘clock’ problem is one of 7 sub-sites under a Department Chief.

    3.       There are 7 sub-sites (sub-departments) under the Department Chief.

    4.       Do I start at the Department Chief site?

    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:35 PM
    Wednesday, August 13, 2008 6:36 PM
  • It sounds like you need to navigate to the one with the clock, and then change the URL.  All of the sites have access to the  '/_layouts/settings.aspx'.  It may just be in the form of http://server/site/_layouts/settings.aspx



    Shannon Bray - MCT, MCPD, MCTS, MCITP
    Wednesday, August 13, 2008 6:38 PM
  • I made it to the site setting page, now where do I go?
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:35 PM
    Wednesday, August 13, 2008 7:17 PM
  •  I can't get you where I thought I could from there.

    Go to the page you need to remove the web part from and alter the URL ...

    place ' ?contents=1' at the end.  This will bring up the Web Part Maintenace Page.


    http://www.shannonbray.com/2008/08/failed-web-part.html


    Shannon Bray - MCT, MCPD, MCTS, MCITP
    Wednesday, August 13, 2008 7:34 PM
  • Seems like the Content Editor web part has problem, just try deleting that web part.

    Append ?Contents=1 at the end of url. Example http://domain/sites/site/default.aspx becomes http://domain/sites/site/default.aspx?contents=1 .. it will give youa list of web parts used on that page. Just select the content editor one & delete it.

    I hope it helps.
    Thanks, Arpit
    Wednesday, August 13, 2008 7:34 PM
  • It worked and thank you very much for your help. I made some step by step 'Screen Shots' for my SharePoint note book.
    Thanks again.
    • Marked as answer by fmorales2 Wednesday, August 13, 2008 8:36 PM
    Wednesday, August 13, 2008 8:16 PM