locked
Deployment failed. FastDev directory creation failed. RRS feed

  • Question

  • User5850 posted

    Hi, When trying to deploy any application from Xamarin Studio to a physical device I get the following error:

    Detecting installed packages
    Removing previous version of application
    Installing application on device
    Deployment failed because the FastDev assembly directory could not be created.
    Deployment failed. FastDev directory creation failed.
    

    On an emulator all works like a charm. Any idea how to debug this?

    The device is: HTC Desire Z with Android 2.3.3

    I'm using: Xamarin Studio Version 4.0.1 (build 9) Runtime: Microsoft .NET 4.0.30319.17929, GTK 2.24.13, GTK# (2.12.0.0)

    Xamarin.Android Version: 4.6.0 Android SDK: C:\Users\K\AppData\Local\Android\android-sdk Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31

    Operating System Windows 6.1.7601.65536 (64-bit)

    Saturday, March 16, 2013 11:06 AM

All replies

  • User5850 posted

    For testing I tried deploying many apps - also from xamarin sample app repository.

    Before the "Deployment failed. FastDev directory creation failed." msg in the IDE the app crashes on the phone.

    And I was able to deploy on the same phone using the same software stack any app no longer than a day ago. Any ideas?

    Saturday, March 16, 2013 11:18 AM
  • User5850 posted

    Edit: < thought that I've fixed it - I haven't >

    Saturday, March 16, 2013 2:31 PM
  • User209 posted

    Have you tried disabling fast deployment? In VS you can do it in the project options. Not sure how to do it in XS.

    Sunday, March 17, 2013 8:56 AM
  • User6047 posted

    Hi, I've having the same problem, and I turn off the Fast Deployment in Xamarin Studio and it work's for me:

    Project / Project Options / Android Build / Fast deployment

    Thursday, March 21, 2013 12:57 AM
  • User5850 posted

    It worked - thank you.

    Friday, March 22, 2013 11:25 AM
  • User6467 posted

    Hi,

    I've made changes my assembly.cs file... deploy... and got the same error. I also turned off fast deployment like sandro and it works.

    After Rollback changes I'm turned on fast deployment and it works...

    I changed the Application Attributes, commented "Name"... that was the reason for my error:

    [assembly: Application (
        Debuggable=true,
        Label="@string/app_name",
        Icon = "@drawable/icon_easygo",
        //Name=".MonoDroidEasyGo.EasyGoMain",
        Theme="@style/customTitleWithBar"
        )]
    

    D.P.

    Tuesday, March 26, 2013 9:57 AM
  • User48 posted

    As per the remarks of the ApplicationAttribute.Name property:

    This value cannot follow the Android "shortcut" of using . as the first character; it must be a fully-qualified type name.

    You're using an invalid value.

    Wednesday, March 27, 2013 3:14 AM
  • User6467 posted

    Thanks jonp :)

    Wednesday, March 27, 2013 7:33 AM
  • User9767 posted

    I had the same issue when changing the Main Activity of my app. After removing the old version from the device, and rebuilding and installing on the device with the new Main Activity it worked.

    Thursday, April 25, 2013 8:52 AM
  • User3486 posted

    In addition it looks like you need to lowercase the namespace in application attribute.

    Thursday, May 9, 2013 7:13 PM
  • User13579 posted

    I've turned off the "Use Fast Deployment(debug mode only)" still it's not working. The following error shows: This project does not contain any activities marked MainLauncher. It has been deployed to the device, but no activity will be launched.

    To mark an activity as launchable, add the [Activity] attribute to it with MainLauncher = true:

    [Activity (MainLauncher = true)] public class MyActivity : Activity { }

    Please kindly help me to get out of this.

    Sunday, June 2, 2013 7:16 AM
  • User20007 posted

    Hi Any one Can Help

    My Android app is not deploy when i run.for more info please look forum link: http://forums.xamarin.com/discussion/6994/after-the-emulator-starts-up-and-slide-the-lock-button-my-apps-not-installed-means-it-s-not-display?new=1

    Saturday, August 17, 2013 7:03 AM
  • User12112 posted

    I had the same issue. As per @AdrianCooke, I also manually uninstalled the app from Android and then deployment started working again.

    Sunday, September 1, 2013 1:32 PM
  • User447 posted

    I had the same issue. As per @AdrianCooke, I also manually uninstalled the app from Android and then deployment started working again.

    Me too. I think the problem was that I had actually downloaded my app from Google play and fastdev couldn't remove it.

    Wednesday, October 9, 2013 11:25 AM
  • User19130 posted

    Please refer snapshot.

    Wednesday, October 9, 2013 12:31 PM
  • User1627 posted

    I have the same issue as mentioned above. When unchecking the fast deployment, i get a fatal exception.

    [AndroidRuntime] Shutting down VM [AndroidRuntime] FATAL EXCEPTION: main [AndroidRuntime] Process: ColorUtils.ColorUtils, PID: 9936 [AndroidRuntime] java.lang.RuntimeException: Unable to get provider mono.MonoRuntimeProvider: java.lang.RuntimeException: Unable to find application Mono.Android.DebugRuntime or Mono.Android.Platform.ApiLevel_19! [AndroidRuntime] at android.app.ActivityThread.installProvider(ActivityThread.java:4793) [AndroidRuntime] at android.app.ActivityThread.installContentProviders(ActivityThread.java:4385) [AndroidRuntime] at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4325) [AndroidRuntime] at android.app.ActivityThread.access$1500(ActivityThread.java:135) [AndroidRuntime] at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1256) [AndroidRuntime] at android.os.Handler.dispatchMessage(Handler.java:102) [AndroidRuntime] at android.os.Looper.loop(Looper.java:136) [AndroidRuntime] at android.app.ActivityThread.main(ActivityThread.java:5017) [AndroidRuntime] at java.lang.reflect.Method.invokeNative(Native Method) [AndroidRuntime] at java.lang.reflect.Method.invoke(Method.java:515) [AndroidRuntime] at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:779) [AndroidRuntime] at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:595) [AndroidRuntime] at dalvik.system.NativeStart.main(Native Method) [AndroidRuntime] Caused by: java.lang.RuntimeException: Unable to find application Mono.Android.DebugRuntime or Mono.Android.Platform.ApiLevel_19! [AndroidRuntime] at mono.MonoRuntimeProvider.attachInfo(MonoRuntimeProvider.java:30) [AndroidRuntime] at android.app.ActivityThread.installProvider(ActivityThread.java:4790) [AndroidRuntime] ... 12 more [AndroidRuntime] Caused by: android.content.pm.PackageManager$NameNotFoundException: Mono.Android.Platform.ApiLevel_19 [AndroidRuntime] at android.app.ApplicationPackageManager.getApplicationInfo(ApplicationPackageManager.java:227) [AndroidRuntime] at mono.MonoRuntimeProvider.attachInfo(MonoRuntimeProvider.java:22) [AndroidRuntime] ... 13 more [Process] Sending signal. PID: 9936 SIG: 9

    Note, this is a hello, world app, no code has been changed or added. this is only for new projects, old projects still deploy properly. everything was working fine before, no OS or XS changes have been made.

    Monday, February 10, 2014 10:10 AM
  • User1627 posted

    ok i solved it by changing the target framework. It was set to automatically choose the latest. I changed it to select a specified framework and although it was the same, it solved the problem.

    Monday, February 10, 2014 10:58 PM
  • User17308 posted

    Thank you Cheesy! Turning off FastDeployment fixed the problem.

    Saturday, March 15, 2014 9:21 PM
  • User44998 posted

    I turn off FastDeployment but then the app crashes on create

    Wednesday, March 26, 2014 9:45 PM
  • User49380 posted

    Its works for me now with FastDev option off. I was working with Xamarin on Mac and testing on Galaxy S4. First my S4 wasn't showing up in the running list. Then after Kies finally figured out the device, I had a "Security notice, An attempt to access a secure area ..." in my S4.

    Then Finally I hit the FastDev error that got me here. Thanks guys.

    Friday, April 25, 2014 6:40 AM
  • User35 posted

    Could I ask those of you that fixed this problem by turning FastDev off to update bug 18543 with the logs from your AndroidTools? It would really help with troubleshooting this issue.

    Thanks.

    Monday, April 28, 2014 1:41 PM
  • User447 posted

    I had the same issue. As per @AdrianCooke, I also manually uninstalled the app from Android and then deployment started working again.

    I think the problem was that I had actually downloaded my app from Google play and fastdev couldn't remove it.

    Tuesday, April 29, 2014 1:42 AM
  • User39390 posted

    I changed the Target Framework like 'bny' mentioned and it worked for me. Thanks alot :-)

    I did this by going in 'Xamarin Studio' to: Project/%projectname% Options/Android Application. There I changed my "Minimum Android Version" and "Target Android Version"

    Friday, May 2, 2014 9:11 AM
  • User51385 posted

    Good answer to disable FastDep build but for me just doing the old: "Build / Clean All" and "Build / Build All" did the trick.

    Monday, July 7, 2014 3:09 PM
  • User50317 posted

    Clean All and Rebuild worked for me also

    Thursday, July 10, 2014 6:01 PM
  • User64386 posted

    Thanks guys. Although i cracked my brain before seeing the project solution option in Visual Studio 2013.

    Thursday, July 24, 2014 4:21 PM
  • User154640 posted

    In addition to above points you can also try ... by going to Project --> [Project Name] Options --> Android Build --> Under Advanced I selected X86. Because my error log stated that my Emulator is not supporting X86_X64 architecture. Hence I tried this step.

    Monday, August 31, 2015 2:45 PM
  • User218392 posted

    @Cheesebaron said: Have you tried disabling fast deployment? In VS you can do it in the project options. Not sure how to do it in XS.

    Worked for me..thanx

    Wednesday, May 25, 2016 1:26 PM
  • User361784 posted

    @FaisalWaris said: I had the same issue. As per @AdrianCooke, I also manually uninstalled the app from Android and then deployment started working again.

    It works to me.

    Monday, December 23, 2019 6:45 PM