none
iostream not found. Visual Studio 2015

    Question

  • I downloaded VS 2015 for class so that I could work on my code at home. I downloaded with out any problems, but when I transferred code and tried to run the code it said <iostream> not found. What do I do so that I can use iostream? Any suggestions?
    Sunday, February 07, 2016 12:58 AM

Answers

All replies

  • Have a look at this issue with VS2010: http://stackoverflow.com/questions/10055399/visual-studio-2010-cant-find-iostream

    There are link to msdn to check on what's included in your compilation here (/ShowIncludes) and here (/P preprocess) to start debugging what's missing.


    You could also come back here and tell us what's files are included and the statements in your compiler ($(VCInstallDir)include; $(VCInstallDir)atlmfc\include; $(WindowsSdkDir)include; $(FrameworkSDKDir)\include; and $(VCInstallDir)lib;$(VCInstallDir)atlmfc\lib;$(WindowsSdkDir)lib;$(FrameworkSDKDir)\lib)

    Maybe it's just a broken VS install after all and some files are missing or just directives....


    Cyrille Precetti <br/>

    Sunday, February 07, 2016 10:51 AM
  • If Cyrille's suggestions don't work for you,

    Two things:

    1. Have you tried to repair your VS 2015 installation? If not, please try that.

    2. As your issue is specific to C++, you may want to ask the C++ gurus here:

    https://social.msdn.microsoft.com/Forums/en-US/vcgeneral/threads

    Sunday, February 07, 2016 3:49 PM
  • I am having this same issue.

    What is the solution?

    Saturday, January 07, 2017 4:52 PM