none
SQL Server Management Studio 2008 on XP Pro x64 RRS feed

  • Question

  • I am trying to install SQL Server Management Studio 2008 on a brand new XP Pro x64 machine.  The machine has .NET framework 3.5 already, but the installation can't seem to find it.  When the install tries to install 3.5 framework itself, it bombs. 

    I have tried to repair the 3.5 framework, and even uninstalled and reinstalled with no change.

    I have search for hours, but none of the threads I found see to address this specific issue.  I do have admin rights on the box (I have been installing other apps as well).

    Links, Ideas?

    Thanks.
    • Moved by nobugzModerator Saturday, July 26, 2008 12:15 AM setup issue (Moved from 64-Bit .NET Framework Development. to .NET Framework Setup)
    Thursday, July 24, 2008 11:00 PM

Answers

  • Well, I figured it out.  Our configuration guy put the installer on a shared drive for me to run.  It took me this long to realize that he provided me the wrong version.  I was trying to install the x386 version.  Once I got the x64 version, everything worked fine.  Sorry about that.
    • Marked as answer by Figo Fei Wednesday, July 30, 2008 2:27 AM
    Wednesday, July 30, 2008 12:48 AM

All replies

  • What was the SQL SMS complaining about when it failed to install?
    And on the other hand, you can use .NET Framework setup verification tool available for download here: http://astebner.sts.winisp.net/Tools/netfx_setupverifier_new.zip
    It can be used to verify all versions of the .NET Framework (1.0, 1.1, 2.0, 2.0 SP1, 3.0, 3.0 SP1 and 3.5) on any supported OS and processor architecture.

    For more information, see:
    http://blogs.msdn.com/astebner/archive/2008/03/03/8015158.aspx

    Thanks.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, July 28, 2008 5:43 AM
  • The verifier was able to verify all versions from 2.0 up, but failed on 1.0 and 1.1.  (my 32 bit machine does the same thing*).

    When I run the installer for SQL SMS 2008 I get a prompt that say .NET framework 3.5 and an updated windows installer need to be installed.  I click OK to continue which should try to install these prerequisites (even though they are already there).

    Instantly another message box shows up with a message that .NET 3.5 installation failed.  Press Ok and installation is terminated.  No logs, no additional info.

    *When I run the .NET validator on my 32 bit machine, where everything runs fine, it fails on the 3.0 SP1 and 3.5 framework.  These versions are obviously working fine on that machine, so the validator seems to be overly sensitive to what is needed to validate the installs.
    Monday, July 28, 2008 3:31 PM
  • So can you please run the .NET Framework 3.5 again from http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en and if it fails again please follow the steps below for more information: What to do when you go to post a setup and deployment issue on the MSDN forums?
    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx

    Then we could diagnose the problem further.

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, July 29, 2008 3:23 AM
  • Well, I figured it out.  Our configuration guy put the installer on a shared drive for me to run.  It took me this long to realize that he provided me the wrong version.  I was trying to install the x386 version.  Once I got the x64 version, everything worked fine.  Sorry about that.
    • Marked as answer by Figo Fei Wednesday, July 30, 2008 2:27 AM
    Wednesday, July 30, 2008 12:48 AM