locked
Entity Data Model from Oracle 11g RRS feed

  • Question

  • User651193107 posted

    Hi,

    i'm pretty new to .NET.

    I tryied to create an "Entity Data Model" from an Oracle 11g Database in Visual Studio 2010.

    But i can't choose the OracleDB/ an Oracle Provider in the dialog where the data sources are listed. Only SQL Servers can be chosen.

    The creation of DataSets do work, i can connect to the Oracle DB, but not when i want to craete an "Entity Data Model" from the oracle db.

     

    Can anybody help me ?

    I write more information on my system and the components version, when necessary.

     

    King regards

    Tobias

    Friday, February 10, 2012 9:07 AM

All replies

  • User1759999623 posted

    The Oracle Data Provider for .NET should work with the Entity Framework.  Look at the following article for more information:

    http://www.oracle.com/technetwork/issue-archive/2011/11-sep/o51odt-453447.html

     

    Friday, February 10, 2012 9:22 AM
  • User651193107 posted

    I downloaded it and installed it. (ODAC 11.2.0.1.2 for my 11.2.0.1.0 oracle db,  the installation worked)

    But nothing changed. I still can't choose my oracle db as data source for the entity data model.

    Friday, February 10, 2012 9:47 AM
  • User1759999623 posted

    Try adding a connection to your Oracle database in the Server Explorer.  If this succeeds, then try add an EDM for your Oracle data source again.

    Friday, February 10, 2012 10:06 AM
  • User651193107 posted

    Ah i explored the Server-Explorer Window. The Connection to my Oracle Database is in there, maybe because i created a dataset from it.

    But i still can't use my oracle db as a source for the EDM  :-(

    Friday, February 10, 2012 10:13 AM
  • User1759999623 posted

    Can you provide the step-by-step approach that you are using to create an EDM with an Oracle data source?

    Friday, February 10, 2012 1:53 PM
  • User651193107 posted

    My Project is open, i see the datasource view.

    In this data source view i click "Add new datasource" --> choose "Database" --> choose "Entity Data Model" --> choose "generate from database" --> in the dialog "choose your data connection" i choose "new connection" --> dialog datasource appears, in this dialog a can only choose SQL Databases, even under the option "others" i can only choose SQL Databases and no Oracle..

    Monday, February 13, 2012 8:46 AM
  • User1759999623 posted

    Check to see that Oracle is working within Visual Studio.  Go to the Tools menu and see if you have menu item SQL*Plus.  If you do not see this, then you need to reinstall the Oracle Developer Tools.

    Wednesday, February 15, 2012 3:05 PM
  • User651193107 posted

    Hi Careed,

    i can execute sql scripts through the sql*plus in Visual Studio 2010.

    But i still can't choose my Oracle 11g database as datasource to generate an Entity Data Model.

     

     

    Friday, February 17, 2012 4:29 AM
  • User1759999623 posted

    Do you have the latest version of ODT?  I just recently installed the latest version and I am able to connect to an Oracle 11g database using EF in VS 2010.  I know that it can be done; however, you need to have the latest version of both the ODT and probably even 11g.

    Friday, February 17, 2012 9:04 AM
  • User1444151195 posted

    My Project is open, i see the datasource view.

    In this data source view i click "Add new datasource" --> choose "Database" --> choose "Entity Data Model" --> choose "generate from database" --> in the dialog "choose your data connection" i choose "new connection" --> dialog datasource appears, in this dialog a can only choose SQL Databases, even under the option "others" i can only choose SQL Databases and no Oracle..

     

    Even I am getting same issue.

    Sunday, March 18, 2012 5:45 PM
  • User1759999623 posted

    This would indicate to me that you do not have the EF functionality from Oracle either completely installed or properly installed.  I would recommend reinstalling the ODT.

    Sunday, March 18, 2012 8:19 PM
  • User1444151195 posted

    Thanks careed.

    I reinstalled the oracle again. I am getting the option now.

     

    Sunday, March 18, 2012 9:02 PM